summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 06:07:23 +0000
committerSam James <sam@gentoo.org>2021-12-29 06:27:09 +0000
commitbbf303a2bd691cc0c9165b5435db1a8f6f19a32a (patch)
tree23aa2f321a8c16a24fa5550ad96f64cd297e0ede /app-misc/evtest
parentdev-python/pytables: add 3.7.0 (diff)
downloadgentoo-bbf303a2bd691cc0c9165b5435db1a8f6f19a32a.tar.gz
gentoo-bbf303a2bd691cc0c9165b5435db1a8f6f19a32a.tar.bz2
gentoo-bbf303a2bd691cc0c9165b5435db1a8f6f19a32a.zip
app-misc/evtest: fix musl build (upstream patch)
Closes: https://bugs.gentoo.org/716876 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/evtest')
-rw-r--r--app-misc/evtest/evtest-1.34.ebuild13
-rw-r--r--app-misc/evtest/files/evtest-1.34-musl-include.patch26
2 files changed, 34 insertions, 5 deletions
diff --git a/app-misc/evtest/evtest-1.34.ebuild b/app-misc/evtest/evtest-1.34.ebuild
index a78f06daa8ee..dd74ba04b33a 100644
--- a/app-misc/evtest/evtest-1.34.ebuild
+++ b/app-misc/evtest/evtest-1.34.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,13 +13,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-BDEPEND="virtual/pkgconfig"
-
-DEPEND="app-text/asciidoc
- app-text/xmlto"
+BDEPEND="app-text/asciidoc
+ app-text/xmlto
+ virtual/pkgconfig"
S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-include.patch
+)
+
src_prepare() {
default
eautoreconf
diff --git a/app-misc/evtest/files/evtest-1.34-musl-include.patch b/app-misc/evtest/files/evtest-1.34-musl-include.patch
new file mode 100644
index 000000000000..7bf7f044c684
--- /dev/null
+++ b/app-misc/evtest/files/evtest-1.34-musl-include.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/716876
+https://cgit.freedesktop.org/evtest/commit/?id=049396aab18849eef257af1116951a83416339e6
+
+From: Mateusz Piotrowski <0mp@FreeBSD.org>
+Date: Fri, 13 Nov 2020 13:41:41 +0100
+Subject: Remove PATH_MAX
+
+This makes evtest more portable. We could try to use ifdefs to include
+sys/syslimits.h on FreeBSD to get PATH_MAX but it feels to be an
+overkill for evtest. Let's keep it simple as just replace PATH_MAX with
+4096.
+
+NB: it's fine to leave linux/input.h there, because this header is
+actually available on FreeBSD via the devel/evdev-proto port.
+--- a/evtest.c
++++ b/evtest.c
+@@ -888,7 +888,7 @@ static char* scan_devices(void)
+
+ for (i = 0; i < ndev; i++)
+ {
+- char fname[PATH_MAX];
++ char fname[4096];
+ int fd = -1;
+ char name[256] = "???";
+
+cgit v1.2.1