summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-01-21 17:19:32 -0800
committerYixun Lan <dlan@gentoo.org>2024-01-31 10:21:47 +0000
commit133c21f8eda091b6d94602177a8660b8f6b4ec16 (patch)
treeb8c2507af7c6ac77814f8f3252b0f4c3f8d41d7e /app-misc/datefudge
parentsys-apps/debianutils: drop installkernel-systemd (diff)
downloadgentoo-133c21f8eda091b6d94602177a8660b8f6b4ec16.tar.gz
gentoo-133c21f8eda091b6d94602177a8660b8f6b4ec16.tar.bz2
gentoo-133c21f8eda091b6d94602177a8660b8f6b4ec16.zip
app-misc/datefudge: add 1.26
Closes: https://github.com/gentoo/gentoo/pull/34952 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-misc/datefudge')
-rw-r--r--app-misc/datefudge/Manifest1
-rw-r--r--app-misc/datefudge/datefudge-1.26.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/datefudge/Manifest b/app-misc/datefudge/Manifest
index 90fffe75a16b..88439c45d3f3 100644
--- a/app-misc/datefudge/Manifest
+++ b/app-misc/datefudge/Manifest
@@ -1 +1,2 @@
DIST datefudge_1.24.tar.xz 14152 BLAKE2B c0a386193e6761abade4643e2f56520738baf4bb739d4c94cec3e47a8feb5ebdf32a6e8b4a0c3dbb9584136b9855abcc68f5134e082083dfb61e977ae45c0bc7 SHA512 cd548a7e8ff10189e101fa339b2845cdd19a59354e43b02cf47e466855ec192dc2084951f7663a94da56a580dd24524047651d8bcb41aa478fe94b24dffaedeb
+DIST datefudge_1.26.tar.xz 14872 BLAKE2B fb8edc9ccf86af1357b49b2fd0b19c5b6a75a49c317baeb2915c56f9c1fa561d69cd37c8f3702cbe543f2747eab5bd1a1908788e3a8f29feb30bb42ec9a55636 SHA512 04255dcf3b8c552d14434fa9022c5970063a5d42d2b9526398894c3d926d91b380ef729565c72391b03981cabacdc9eb7eac29dc8cd6b462a9483b01e8a64d71
diff --git a/app-misc/datefudge/datefudge-1.26.ebuild b/app-misc/datefudge/datefudge-1.26.ebuild
new file mode 100644
index 000000000000..1cfd453e0b94
--- /dev/null
+++ b/app-misc/datefudge/datefudge-1.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A program (and preload library) to fake system date"
+HOMEPAGE="https://packages.qa.debian.org/d/datefudge.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/dpkg-parsechangelog/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" VERSION="${PV}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" install
+ einstalldocs
+}