summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-04 09:27:45 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-04 09:43:31 +0100
commit74d679f06c836f7919b44741e0eafc43db7bfba0 (patch)
treeeee20a036f2955b17af3c1531e182f3455738430 /app-emacs/vertico
parentapp-emacs/vertico: drop old 1.3 (diff)
downloadgentoo-74d679f06c836f7919b44741e0eafc43db7bfba0.tar.gz
gentoo-74d679f06c836f7919b44741e0eafc43db7bfba0.tar.bz2
gentoo-74d679f06c836f7919b44741e0eafc43db7bfba0.zip
app-emacs/vertico: bump to 1.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/vertico')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-1.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index d122bc33dfdc..2a4f7fd92cf6 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1 +1,2 @@
DIST vertico-1.4.tar.gz 45260 BLAKE2B 199472fd9126bdb940eeac811c19f4a9f8efe5c5a31ce580ab148db23bb69bb47c71ec9299339e768fd8662dd38fe39e469d4548cd8c15b761a1b282d5bcbf67 SHA512 2ff48178807e5bd32d8515bc3a1c435be191b1383ca749cdaca8e15140c86253b6b5073c883c080ded42f6ec511acd4292b1cce415a696911f5f932a0de167f3
+DIST vertico-1.5.tar.gz 47160 BLAKE2B 4d85b4cda2692cb71519abf0455aa5871ee1bf773cc3d5835e097b1879bd62ea713c3291de554a0dc8a0968f67a0293c1855a537dc133d0a63ffc6bb472a8989 SHA512 b9a1ec26cbec75f1b3561cfc92095cec9bb386ff6020acbe1297f90b22d73cde39a65ed51cf4cec6c33939c974eb098a5d0b3126bafb0699a994d65cbff40614
diff --git a/app-emacs/vertico/vertico-1.5.ebuild b/app-emacs/vertico/vertico-1.5.ebuild
new file mode 100644
index 000000000000..8623d46e2c78
--- /dev/null
+++ b/app-emacs/vertico/vertico-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el ./ || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}