summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2023-03-12 21:00:50 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-04-03 11:00:21 +0300
commit5ca93095d379c8afdbf4bb5f2ae23c4ee32e9b25 (patch)
tree90f03903e45e1e8861fede0bf6b8c457493c70ca /app-cdr
parentapp-backup/mkstage4: updated tests, EAPI bump (diff)
downloadgentoo-5ca93095d379c8afdbf4bb5f2ae23c4ee32e9b25.tar.gz
gentoo-5ca93095d379c8afdbf4bb5f2ae23c4ee32e9b25.tar.bz2
gentoo-5ca93095d379c8afdbf4bb5f2ae23c4ee32e9b25.zip
app-cdr/cdrdao: add 1.2.5
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/30082 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdrdao/Manifest1
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.5.ebuild53
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch10
3 files changed, 64 insertions, 0 deletions
diff --git a/app-cdr/cdrdao/Manifest b/app-cdr/cdrdao/Manifest
index ee9143b59282..c66587c5f8c2 100644
--- a/app-cdr/cdrdao/Manifest
+++ b/app-cdr/cdrdao/Manifest
@@ -1 +1,2 @@
DIST cdrdao-1.2.4.tar.gz 1603363 BLAKE2B 9c22d21a391b6b1b6ded19f88506acd22e681a43ed91b1c71d20de27ce93cc74381d4efe8574adc929a189143c81f5838ca8d8227ec0e2e05a593f0df9547964 SHA512 decdc9d83fe380a4a05443ac26366eb3288d24bd7ed6c16d006707abb616dab91858a59af6638f2d7a72bc7bb6425dbfddd119ca492d18f07afbb27341b23d0b
+DIST cdrdao-1.2.5.tar.gz 858440 BLAKE2B 6b7f11968335f3c07df2bfc8cbfd53d65a42413026206c47f9bdc792d30faa91f3e9285fd36d884ee42cb31103f666097fb55c8f382202f4e9d2d4ddd4685527 SHA512 790468a28e5ba96421c83c2101f61f479099782bc28677c7f52b94990de258e3caf7f77d3105e3e826d848b9488182880857335b1bcfbfca033d9e1fc56d193b
diff --git a/app-cdr/cdrdao/cdrdao-1.2.5.ebuild b/app-cdr/cdrdao/cdrdao-1.2.5.ebuild
new file mode 100644
index 000000000000..126b1c4d9a3d
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_PV="rel_${PV//./_}"
+DESCRIPTION="Burn CDs in disk-at-once mode with a command line interface"
+HOMEPAGE="https://github.com/cdrdao/cdrdao/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="encode mad vorbis"
+
+DEPEND="app-cdr/cdrtools
+ encode? ( >=media-sound/lame-3.99 )
+ mad? (
+ media-libs/libao
+ media-libs/libmad
+ )
+ vorbis? (
+ media-libs/libao
+ media-libs/libvorbis
+ )"
+RDEPEND="${DEPEND}
+ !app-cdr/cue2toc"
+BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-remove-gconf-dep.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ filter-lto # https://bugs.gentoo.org/854219
+
+ local myeconfargs=(
+ --without-gcdmaster
+ $(use_with vorbis ogg-support)
+ $(use_with mad mp3-support)
+ $(use_with encode lame)
+ )
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch b/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch
new file mode 100644
index 000000000000..fc493abc71f2
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,6 @@
+ AC_CONFIG_HEADERS(config.h)
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST
+-AM_GCONF_SOURCE_2
+ AM_ICONV
+
+ AC_ARG_WITH(pcctsbin,[ --with-pcctsbin=dir set directory of PCCTS parser generator executables],[pcctsbin=$withval],[pcctsbin=default])