summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-03 04:39:18 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-03 04:41:49 +0100
commit6df1dc347171439b6894a9d27151d761be480ec4 (patch)
treebdf28f80b16b7dd00ae0b22a8d2819d287a4e8d6 /app-arch
parentapp-arch/stormlib: Remove old (diff)
downloadgentoo-6df1dc347171439b6894a9d27151d761be480ec4.tar.gz
gentoo-6df1dc347171439b6894a9d27151d761be480ec4.tar.bz2
gentoo-6df1dc347171439b6894a9d27151d761be480ec4.zip
app-arch/stormlib: Bump to 9.30
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/stormlib/Manifest1
-rw-r--r--app-arch/stormlib/stormlib-9.30.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/stormlib/Manifest b/app-arch/stormlib/Manifest
index cd551303840f..e305a8334a67 100644
--- a/app-arch/stormlib/Manifest
+++ b/app-arch/stormlib/Manifest
@@ -1 +1,2 @@
DIST StormLib-9.26.tar.gz 610223 BLAKE2B 670296e5d1f9d2b22d5f6cad214ff7076fdc5078c7aa6d13458e06b4b44b62acf2bd68689a05c630db024ea3d54bbc5be14855d757a1b31475664a593fb5db60 SHA512 5f0ce75019cfbe3a2dfc07ea312825e2babf226dbf8aa77ed60456862ae739ac4689cbe7d4a185cdc148ad9910fd8137d3f11c04ffe6c532bbdacb08838ecfba
+DIST StormLib-9.30.tar.gz 617848 BLAKE2B 214289082ad65007d8222663d64a65d55eac32d9aa56d3cd341bbfd16a8e2df748b8dd1d0244e3f12750bd6793ad014031ff91bb630f7445d1d2ebee26769249 SHA512 11da94507661c949fd402d06d303323af9964bfa1121226a3fde8858f18aa827b13375ab08e4751f7b4baef01464417898bcd3f29da1aa94083710dcafa1d1f9
diff --git a/app-arch/stormlib/stormlib-9.30.ebuild b/app-arch/stormlib/stormlib-9.30.ebuild
new file mode 100644
index 000000000000..7aed4f097953
--- /dev/null
+++ b/app-arch/stormlib/stormlib-9.30.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P=StormLib-${PV}
+DESCRIPTION="Library to read and write MPQ archives (Diablo, StarCraft)"
+HOMEPAGE="
+ http://www.zezula.net/en/mpq/stormlib.html
+ https://github.com/ladislav-zezula/StormLib/
+"
+SRC_URI="
+ https://github.com/ladislav-zezula/StormLib/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libtomcrypt:=[libtommath]
+ sys-libs/zlib:=
+"
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ # interactive test app
+ -DSTORM_BUILD_TESTS=OFF
+ -DWITH_LIBTOMCRYPT=ON
+ )
+
+ cmake_src_configure
+}