summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-10-26 23:37:10 +0300
committerSam James <sam@gentoo.org>2023-10-27 03:53:09 +0100
commit2c5c6ee980734ef47079ca06fe02dfc2b783d54d (patch)
tree4ab8bbc52caa72c83cb042635e948741f7dfb53f /app-arch
parentgui-apps/waypipe: fix BetterCompressionUri, drop unnecessary rename (diff)
downloadgentoo-2c5c6ee980734ef47079ca06fe02dfc2b783d54d.tar.gz
gentoo-2c5c6ee980734ef47079ca06fe02dfc2b783d54d.tar.bz2
gentoo-2c5c6ee980734ef47079ca06fe02dfc2b783d54d.zip
app-arch/patool: add 1.14.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/patool/Manifest1
-rw-r--r--app-arch/patool/patool-1.14.1.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/app-arch/patool/Manifest b/app-arch/patool/Manifest
index a4da6050d14d..fa98f8effcba 100644
--- a/app-arch/patool/Manifest
+++ b/app-arch/patool/Manifest
@@ -1,2 +1,3 @@
DIST patool-1.12.tar.gz 69146 BLAKE2B e97f64b4ba41860c1f7e506f63f249adeb02974b71bf83eb1673ae1fd93b8f9b698818cb57f961b3d3a5d4e445c5e7a3a349db54e1eb11a8fc165ad07722ace9 SHA512 b8c67526ce79448de703b03ca9b363c0e04cfe56bfc6168bcb96202f95022b6bbcaa92be86a85ee9608070206acd09382b0dfd08a2f805c5e8e5683c7c3f18cc
DIST patool-1.12_p20230424.gh.tar.gz 1990425 BLAKE2B dd0ae58fd26ef1849c26cb681839536b0499d666faf48cb7028adc12840055d72e70a85db99c615c79b076671f16e1371ee5ddbb24228248cd3c1b0daf2dc496 SHA512 c2974bad22ab57aca3aab32e51aeac0c2a2aa3ffee41241d3220151206b8a5d709ec72ea1b4a73a218c03b9fad64297ecd2ab44cc20da5f4d0e4a3ecd5589d43
+DIST patool-1.14.1.tar.gz 1992559 BLAKE2B 3468c6b7779806ecb906830043964f2fa88384569af4cad857d8519568a7670a403ce17ca5b495fae6ad129f109bfac38693bfe651bad54dc5e6a46b5b58ea4f SHA512 df5ce0f5275fcc0b653775b9fbc36e11dfff1fcf30e5caf78bbebbf2c169125c7d27e71481c7ba108d39fb12cebdf3d84ab8c40f1a5f061dea5e5304e2306481
diff --git a/app-arch/patool/patool-1.14.1.ebuild b/app-arch/patool/patool-1.14.1.ebuild
new file mode 100644
index 000000000000..86b157acb084
--- /dev/null
+++ b/app-arch/patool/patool-1.14.1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Portable archive file manager"
+HOMEPAGE="https://wummel.github.io/patool/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-arch/arj
+ app-arch/bzip2
+ app-arch/bzip3
+ app-arch/cabextract
+ app-arch/cpio
+ app-arch/dpkg
+ app-arch/gzip
+ app-arch/lbzip2
+ app-arch/lcab
+ app-arch/lha
+ app-arch/libarchive
+ app-arch/lrzip
+ app-arch/lzip
+ app-arch/lzop
+ app-arch/ncompress
+ app-arch/p7zip[rar]
+ app-arch/pbzip2
+ app-arch/pdlzip
+ app-arch/pigz
+ app-arch/rpm
+ app-arch/sharutils
+ app-arch/tar
+ app-arch/unace
+ app-arch/unadf
+ app-arch/unzip
+ app-arch/xdms
+ app-arch/xz-utils
+ app-arch/zip
+ app-arch/zpaq
+ app-arch/zstd
+ app-cdr/cdrtools
+ dev-libs/chmlib
+ media-libs/flac
+ media-sound/shorten
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/grep
+ !elibc_musl? ( app-arch/rar )
+ !x86? ( app-arch/clzip )
+ )
+"
+# Test dependencies which are packaged but can't be tested for various reasons.
+# app-arch/arc
+# app-arch/zoo
+# app-arch/zopfli
+# media-sound/mac
+
+# app-arch/rar is masked on musl
+# app-arch/clzip is unkeyworded on x86
+
+# Unpackaged testable dependencies
+# archmage
+# genisoimage
+# lhasa
+# nomarch
+# pdzip2
+# py_{bz2,echo,gzip,tarfile,zipfile}
+# rpm2cpio
+# rzip
+# star
+# unalz
+# uncompress.real
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newdoc doc/README.txt README.md
+ doman doc/patool.1
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # zoo emits a non-zero exit status on a possibly false consistency check
+ # Zoo: WARNING: Archive header failed consistency check.
+ "tests/archives/test_zoo.py"
+ # Doesn't accept long arguments, such as those that files in ${S} would have.
+ # Too long argument: /var/tmp/portage/app-arch/patool-1.12_p20230424/work/patool-ab64562c8cdac34dfd69fcb6e30c8c0014282d11/tests/data/p.arc.foo
+ "tests/archives/test_arc.py"
+ # Error: 1002 (invalid input file)
+ "tests/archives/test_mac.py"
+ # AttributeError: module 'patoolib.programs.zopfli' has no attribute 'extract_gzip'
+ "tests/archives/test_zopfli.py"
+ )
+
+ if use elibc_musl; then
+ EPYTEST_IGNORE+=(
+ "tests/archives/test_rar.py"
+ )
+ fi
+
+ if use x86; then
+ EPYTEST_IGNORE+=(
+ "tests/archives/test_clzip.py"
+ )
+ fi
+
+ epytest
+}