summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2021-01-06 21:18:47 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2021-01-06 21:18:47 +0200
commit8e061364b8c461419cbf03aaa7a98b691cbe580b (patch)
treeb9525943c939292209eb55ff88b74a54cee86a93 /app-arch/dump
parentapp-admin/sagan: Apply gcc-10 workaround (diff)
downloadgentoo-8e061364b8c461419cbf03aaa7a98b691cbe580b.tar.gz
gentoo-8e061364b8c461419cbf03aaa7a98b691cbe580b.tar.bz2
gentoo-8e061364b8c461419cbf03aaa7a98b691cbe580b.zip
app-arch/dump: Apply gcc-10 workaround
Quoting upstream: > Mike Frysinger - 5 days ago > the codebase is a mess and not worth my time to untangle, so i just > added -fcommon to the configure script's CFLAGS Closes: https://bugs.gentoo.org/707234 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'app-arch/dump')
-rw-r--r--app-arch/dump/dump-0.4.46-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-arch/dump/dump-0.4.46-r1.ebuild b/app-arch/dump/dump-0.4.46-r1.ebuild
index c768fa8534d8..1ebc6f993745 100644
--- a/app-arch/dump/dump-0.4.46-r1.ebuild
+++ b/app-arch/dump/dump-0.4.46-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit flag-o-matic
+
MY_P="${PN}-$(ver_rs 2 b)"
S=${WORKDIR}/${MY_P}
DESCRIPTION="Dump/restore ext2fs backup utilities"
@@ -53,6 +55,8 @@ PATCHES=(
)
src_configure() {
+ append-flags -fcommon
+
local myeconfargs=(
--with-dumpdatespath=/etc/dumpdates
--with-rmtpath='$(sbindir)/rmt'