summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-27 18:30:55 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:42 +0200
commitfecf67e319addb4a820f79914c55be4b592e7c5d (patch)
tree0663837aeb425c88edbe208013fe50baec19527a
parentwww-client/elinks: update live to use new guile mechanism (diff)
downloadgentoo-fecf67e319addb4a820f79914c55be4b592e7c5d.tar.gz
gentoo-fecf67e319addb4a820f79914c55be4b592e7c5d.tar.bz2
gentoo-fecf67e319addb4a820f79914c55be4b592e7c5d.zip
x11-misc/xbindkeys: switch to new guile mechanism
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
-rw-r--r--profiles/package.mask1
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 028c0d97a91e..e80f0e0496fa 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -395,6 +395,7 @@ dev-scheme/guile:3.0
>=sci-libs/nlopt-2.7.1-r100
>=sys-devel/autogen-5.18.16-r100
>=www-client/elinks-0.16.1.1-r100
+>=x11-misc/xbindkeys-1.8.7-r100
# Eli Schwartz <eschwartz@gentoo.org> (2024-08-15)
# Abandoned upstream since 2011, unmaintained in gentoo since 2017. Tons of
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
new file mode 100644
index 000000000000..4688b3dae019
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_REQ_USE="deprecated"
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile-single
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="guile tk"
+
+REQUIRED_USE="guile? ( ${GUILE_REQUIRED_USE} )"
+
+RDEPEND="
+ x11-libs/libX11
+ guile? ( ${GUILE_DEPS} )
+ tk? ( dev-lang/tk )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO xbindkeysrc )
+
+src_prepare() {
+ default
+
+ use guile && guile_bump_sources
+
+ # Regenerate to pick up newer versions of Guile macros
+ # bug #828532
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable guile) \
+ $(use_enable tk)
+}
+
+src_install() {
+ default
+
+ use guile && guile_unstrip_ccache
+}