summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-09-26 19:21:26 +0100
committerSam James <sam@gentoo.org>2024-11-16 21:39:04 +0000
commita67b483e5caee3d56205b59a0a87b4ff1a09b481 (patch)
tree1c65b7f8086626ce44bd9526be1167d6e440566d
parentdev-ml/lwt: add 5.9.0, drop 5.6.1 (diff)
downloadgentoo-a67b483e5caee3d56205b59a0a87b4ff1a09b481.tar.gz
gentoo-a67b483e5caee3d56205b59a0a87b4ff1a09b481.tar.bz2
gentoo-a67b483e5caee3d56205b59a0a87b4ff1a09b481.zip
sci-mathematics/clipper2: new package, add 1.4.0
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-mathematics/clipper2/Manifest1
-rw-r--r--sci-mathematics/clipper2/clipper2-1.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/clipper2/Manifest b/sci-mathematics/clipper2/Manifest
new file mode 100644
index 000000000000..025aefaf6771
--- /dev/null
+++ b/sci-mathematics/clipper2/Manifest
@@ -0,0 +1 @@
+DIST Clipper2_1.4.0.tar.gz 600352 BLAKE2B 0ba268ba691fde4aef456d8f6ef1810a8c13b77c5bb932296b11b5f0d96dfe70f2d617d7ba013f85817dbc01a800d0ab1fba566e4ab56efde6541c00f3d7f359 SHA512 91036e81244f3615095d7cd8522f9c4a32ea66f802e3d190393eb8939e1a706b69c69c3a5b7c6522235c075dd6ecd45f21bffb47448ba72191ddcf05e9e93128
diff --git a/sci-mathematics/clipper2/clipper2-1.4.0.ebuild b/sci-mathematics/clipper2/clipper2-1.4.0.ebuild
new file mode 100644
index 000000000000..530396047bdf
--- /dev/null
+++ b/sci-mathematics/clipper2/clipper2-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="Clipper2"
+MY_P=${MY_PN}_${PV}
+
+inherit cmake
+
+DESCRIPTION="Polygon Clipping and Offsetting"
+HOMEPAGE="https://www.angusj.com/clipper2/Docs/Overview.htm"
+SRC_URI="https://github.com/AngusJohnson/Clipper2/archive/refs/tags/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_P}/CPP"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLIPPER2_UTILS=OFF
+ -DCLIPPER2_EXAMPLES=OFF
+ -DCLIPPER2_TESTS=OFF
+ -DCLIPPER2_USINGZ=OFF # manifold src/third_party/CMakeLists.txt
+ )
+ cmake_src_configure
+}