summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-13 15:46:54 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-13 15:47:55 +0200
commit775540c91860c850ce01c939982f540ce1b191fb (patch)
tree47ee9054f93df1ab8c71d22641858e6a87c08715
parentnet-analyzer/vnstat: Do not inherit versionator. (diff)
downloadgentoo-775540c91860c850ce01c939982f540ce1b191fb.tar.gz
gentoo-775540c91860c850ce01c939982f540ce1b191fb.tar.bz2
gentoo-775540c91860c850ce01c939982f540ce1b191fb.zip
net-misc/pps-tools: Bump to v1.0.1
Closes: https://bugs.gentoo.org/631760 Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--net-misc/pps-tools/Manifest1
-rw-r--r--net-misc/pps-tools/files/pps-tools-1.0.1-LDFLAGS-fix.patch25
-rw-r--r--net-misc/pps-tools/files/pps-tools-1.0.1-build.patch51
-rw-r--r--net-misc/pps-tools/files/pps-tools-1.0.1-install.patch27
-rw-r--r--net-misc/pps-tools/metadata.xml2
-rw-r--r--net-misc/pps-tools/pps-tools-1.0.1.ebuild27
6 files changed, 132 insertions, 1 deletions
diff --git a/net-misc/pps-tools/Manifest b/net-misc/pps-tools/Manifest
index 6dfdd34fd733..37922cc2cb69 100644
--- a/net-misc/pps-tools/Manifest
+++ b/net-misc/pps-tools/Manifest
@@ -1 +1,2 @@
+DIST pps-tools-1.0.1.tar.gz 12695 SHA256 4bd138d0459f73bc9016dfa72e8c0940797934d47f56f771f740a026592e67cc SHA512 6fe7eba2a1a073a64d40bcc7aef12981414b43656f05fbd84e3ffadf1a074c5aa8d032b39a37095e6846194558b685092b51799fe724fe50cce8f3cbe163f784 WHIRLPOOL cec0e6a80c83186b85f13f50a7a144d63ae51e173e29902220d31c00ab7072387d0bdda846ea2738e4a7697b6e83ec69f82c2e5af92532f9ff9677f7d54c9ac2
DIST pps-tools-git-0.0.20120407.tar.gz 13619 SHA256 eb020d40a3938546620889bb6ecdeead2c188e87ffd43c3ae04a41e5998e7997 SHA512 d2014262b0594959f337c25df859591d0737994decec663389392d3c7e53376ded2485713f6364c4833d8d7c40b4b0c3b88865ab85e481bcc2e81e35931d84de WHIRLPOOL 03ff250da63ff2ca2f9111b8207608e0e989c376a5af51b919d4fb8889936e00db2b15d14309dda68e92e13c7478f81e5a2d72544eefa73eb93287dd0396fc14
diff --git a/net-misc/pps-tools/files/pps-tools-1.0.1-LDFLAGS-fix.patch b/net-misc/pps-tools/files/pps-tools-1.0.1-LDFLAGS-fix.patch
new file mode 100644
index 000000000000..868d97138184
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-1.0.1-LDFLAGS-fix.patch
@@ -0,0 +1,25 @@
+From 231123e1b275f88000e336a2d80d3d96c470ac5e Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Fri, 13 Oct 2017 15:10:08 +0200
+Subject: [PATCH] We need LDLIBS instead of LDFLAGS
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 039795e..a6bff4b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ CFLAGS ?= -O2 -ggdb
+ CFLAGS += -Wall
+ CFLAGS += -fPIC
+ CPPFLAGS += -D_GNU_SOURCE
+-LDFLAGS += -lm
++LDLIBS += -lm
+
+ # -- Actions section --
+
+--
+2.14.2
+
diff --git a/net-misc/pps-tools/files/pps-tools-1.0.1-build.patch b/net-misc/pps-tools/files/pps-tools-1.0.1-build.patch
new file mode 100644
index 000000000000..adc127205afc
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-1.0.1-build.patch
@@ -0,0 +1,51 @@
+From 60a8a9d3195829cc0c2953fd02bdf0a155e0c158 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 18 Aug 2012 17:04:43 -0400
+Subject: [PATCH] fix up makefile
+
+Make sure we respect CFLAGS/CPPFLAGS properly.
+
+Also fix up the depend include so we get reproducible behavior --
+the depend file is generated & included first, and we don't get
+weird behavior when we run:
+ git clean -x -d
+ make
+ make
+
+---
+ Makefile | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c70f073..ec437e2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,9 @@
+ TARGETS = ppstest ppsctl ppswatch ppsldisc
+
+-CFLAGS += -Wall -O2 -D_GNU_SOURCE
+-CFLAGS += -ggdb
++CFLAGS ?= -O2 -ggdb
++CFLAGS += -Wall
+ CFLAGS += -fPIC
++CPPFLAGS += -D_GNU_SOURCE
+ LDFLAGS += -lm
+
+ # -- Actions section --
+@@ -12,11 +13,9 @@ LDFLAGS += -lm
+ all : .depend $(TARGETS)
+
+ .depend depend dep :
+- $(CC) $(CFLAGS) -M $(TARGETS:=.c) > .depend
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -M $(TARGETS:=.c) > .depend
+
+-ifeq (.depend,$(wildcard .depend))
+-include .depend
+-endif
++-include .depend
+
+ install : all
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+--
+2.14.2
+
diff --git a/net-misc/pps-tools/files/pps-tools-1.0.1-install.patch b/net-misc/pps-tools/files/pps-tools-1.0.1-install.patch
new file mode 100644
index 000000000000..8aee2ff459fc
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-1.0.1-install.patch
@@ -0,0 +1,27 @@
+From a530d8853aa6b6ec46236f6ae787cbd37c94e9ba Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 18 Aug 2012 17:15:19 -0400
+Subject: [PATCH] fix DESTDIR installs
+
+Make sure the dirs we install into exist first:
+ make install DESTDIR=$PWD/foo
+
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index ec437e2..039795e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,6 +18,7 @@ all : .depend $(TARGETS)
+ -include .depend
+
+ install : all
++ mkdir -p -m 755 $(DESTDIR)/usr/bin $(DESTDIR)/usr/include/sys
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+ install -m 644 -t $(DESTDIR)/usr/include/sys timepps.h
+
+--
+2.14.2
+
diff --git a/net-misc/pps-tools/metadata.xml b/net-misc/pps-tools/metadata.xml
index 53886946600b..53492db4389e 100644
--- a/net-misc/pps-tools/metadata.xml
+++ b/net-misc/pps-tools/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Base System</name>
</maintainer>
<upstream>
- <remote-id type="github">ago/pps-tools</remote-id>
+ <remote-id type="github">redlab-i/pps-tools</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-misc/pps-tools/pps-tools-1.0.1.ebuild b/net-misc/pps-tools/pps-tools-1.0.1.ebuild
new file mode 100644
index 000000000000..67919d79f146
--- /dev/null
+++ b/net-misc/pps-tools/pps-tools-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space tools for LinuxPPS"
+HOMEPAGE="https://github.com/redlab-i/pps-tools"
+SRC_URI="https://github.com/redlab-i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.1-build.patch
+ "${FILESDIR}"/${PN}-1.0.1-install.patch
+ "${FILESDIR}"/${PN}-1.0.1-LDFLAGS-fix.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}