summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-05-07 20:58:12 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-05-07 20:58:12 +0000
commit3a9992a5d4b89163eda0a3f25e454deb2cec2c57 (patch)
tree4edd7bb684c6de4d6fde00840523a0a40a9ec0f2
parentxfce-extra/xfce4-whiskermenu-plugin: Remove old. (diff)
downloadgentoo-3a9992a5d4b89163eda0a3f25e454deb2cec2c57.tar.gz
gentoo-3a9992a5d4b89163eda0a3f25e454deb2cec2c57.tar.bz2
gentoo-3a9992a5d4b89163eda0a3f25e454deb2cec2c57.zip
www-apps/drupal: Add 8.3.2 release.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.3.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 53f0642f18b6..3257f27a11dd 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,4 @@
DIST drupal-7.54.tar.gz 3275864 SHA256 d74192aca31b56a95bd2b51f205e45293513466eaf902d056e6317dbcffe715b SHA512 0b2834cd2ec7778de1515b99ac7f6348c5a3632a670b882fcce1e3b9d4cc904f9da761c103a3fe70311c69563c8ba5178d76ac8e2938d0831d7ef4113abaaf2a WHIRLPOOL 7aefbecabf5902f97621c3a9ba5cda355a8024390ddfa198dbd20f6ed55187b658fcdb0f39db92a7c7f4e73249d4d191969c8ff9a5d5b13764677a0f50d20f4c
DIST drupal-8.2.8.tar.gz 12092176 SHA256 84b729f45fe6c0f23e15aab7f2c9e57414edec00630ab09bed7dc9e79cac71bb SHA512 3d0b8b8d17042c44f72b28262a183daa6a7eac34759ee0f909fc51b9009c9238d3e64e98a71da8fb28682b4867f0d11868005eddc28249e0e3e59ca00cbc7c01 WHIRLPOOL 26967439cb977fed89361c9c1f8a927e5457e543d61dc2eb6243a270ae1e7aa1dab3099c8a27dffe7a80fdcdd6b7ebd4e2176dee64df866d0e9d4217f57f8eac
DIST drupal-8.3.1.tar.gz 12663939 SHA256 ea855ac6cc6dcc05494c93e6cf65dfe0a8006135ecd21bf6f0f345e7d5222c10 SHA512 699de379f5747a781b08c0b7b7ec7cb8d70f6490b1793e5f5911c7bb654c49454df1e0eb53583adf0fbc31a9b045a8c77ac8fc7f175d6839d859305713f81b8a WHIRLPOOL 064f6b1521df909f6e6f8f77820ac0c09446766f02b2bcf3803ab443f38275f239e91420a0769312a8ea7f01cb217fe5b617d03178c00aa648a3e79b23a2b8c1
+DIST drupal-8.3.2.tar.gz 12698347 SHA256 5afab2a639d8651cb009835a390e0e7d1322d39989dfe20f6be5a79a0b946b1e SHA512 f6b80ce7b000aa8785ca4c35f3a6bc33d0f29448d73f41378a53474dc1522d0576224d7854da095483ac989b4b260fe2348879f3b93eeb55c2ed5428bf742e20 WHIRLPOOL 86dbf9fd41bf474b8595c1532f5e023a2d75b6619273d6ee3c3275872e81eca123cb077c297492cc18a10942e8348e7eb3d30a574cc3779a7bcb3b35f80cb372
diff --git a/www-apps/drupal/drupal-8.3.2.ebuild b/www-apps/drupal/drupal-8.3.2.ebuild
new file mode 100644
index 000000000000..d0f9fcc2d95e
--- /dev/null
+++ b/www-apps/drupal/drupal-8.3.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}