aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-09-04 14:20:13 -0500
committerWilliam Hubbs <williamh@gentoo.org>2011-09-04 14:20:13 -0500
commit6ed3fec8ff1999e98386b9a4cc3c72e49d4ab47c (patch)
tree406fb38c323b6bdf6e9cfcf2974e6bd3bc955e9c
parentUse default openrc stop function (diff)
downloadudev-gentoo-scripts-6ed3fec8ff1999e98386b9a4cc3c72e49d4ab47c.tar.gz
udev-gentoo-scripts-6ed3fec8ff1999e98386b9a4cc3c72e49d4ab47c.tar.bz2
udev-gentoo-scripts-6ed3fec8ff1999e98386b9a4cc3c72e49d4ab47c.zip
Remove baselayout-1 addons
Baselayout-1 has been removed from the tree, so we can remove the baselayout-1 addons.
-rw-r--r--Makefile4
-rw-r--r--addons/udev-start.sh52
-rw-r--r--addons/udev-stop.sh4
3 files changed, 0 insertions, 60 deletions
diff --git a/Makefile b/Makefile
index f6b2535..115763f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,3 @@
-LIBDIR ?= lib
-RCADDON ?= /$(LIBDIR)/rcscripts/addons
LIBUDEV ?= /lib/udev
RULESDIR ?= $(LIBUDEV)/rules.d
SYSCONFDIR ?= /etc
@@ -26,8 +24,6 @@ all:
@echo "Run make install DESTDIR= LIBDIR=lib"
install:
- @install -d $(DESTDIR)$(RCADDON)
- @install -m 0755 addons/* $(DESTDIR)$(RCADDON)
@install -d $(DESTDIR)$(LIBUDEV)
@install -m 0755 $(HELPERS) $(DESTDIR)$(LIBUDEV)
@install -m 0644 $(HELPERS_NOEXE) $(DESTDIR)$(LIBUDEV)
diff --git a/addons/udev-start.sh b/addons/udev-start.sh
deleted file mode 100644
index 98b81ef..0000000
--- a/addons/udev-start.sh
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-[ -e /etc/conf.d/udev ] && . /etc/conf.d/udev
-
-. /lib/udev/shell-compat-addon.sh
-
-compat_volume_nodes()
-{
- # Only do this for baselayout-1*
- # This check is likely to get false positives due to some multilib stuff,
- # but that should not matter, as this can only happen on old openrc versions
- # no longer available as ebuilds.
- if [ ! -e /lib/librc.so ]; then
-
- # Create nodes that udev can't
- [ -x /sbin/lvm ] && \
- /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
- # Running evms_activate on a LiveCD causes lots of headaches
- [ -z "${CDBOOT}" -a -x /sbin/evms_activate ] && \
- /sbin/evms_activate -q &>/dev/null
- fi
-}
-
-start_initd()
-{
- (
- . /etc/init.d/"$1"
- _start
- )
-}
-
-# set it as openrc does
-RC_BOOTLEVEL=${BOOTLEVEL:-default}
-RC_DEFAULTLEVEL=${DEFAULTLEVEL:-default}
-
-# mount tmpfs on /dev
-start_initd udev-mount || exit 1
-
-# Create a file so that our rc system knows it's still in sysinit.
-# Existance means init scripts will not directly run.
-# rc will remove the file when done with sysinit.
-# this is no longer needed as of openrc-0.4.0
-touch /dev/.rcsysinit
-
-# run udevd
-start_initd udev || exit 1
-
-compat_volume_nodes
-
-# udev started successfully
-exit 0
diff --git a/addons/udev-stop.sh b/addons/udev-stop.sh
deleted file mode 100644
index d597281..0000000
--- a/addons/udev-stop.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-exit 0