aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2007-05-01 19:59:47 -0700
committerJosh Triplett <josh@freedesktop.org>2007-05-01 20:01:18 -0700
commitad425f2810b466a000f5556a7710859ca366d135 (patch)
tree23b487dc605cb352acd0e5b81bbd5678c970b1d5 /Makefile
parentgitweb lives at git.kernel.org now. (diff)
downloadsparse-ad425f2810b466a000f5556a7710859ca366d135.tar.gz
sparse-ad425f2810b466a000f5556a7710859ca366d135.tar.bz2
sparse-ad425f2810b466a000f5556a7710859ca366d135.zip
Add a "make dist" that requires $(VERSION) to match `git describe`
Signed-off-by: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index ee9d446..77a6877 100644
--- a/Makefile
+++ b/Makefile
@@ -145,3 +145,10 @@ pre-process.h:
clean:
rm -f *.[oasi] core core.[0-9]* $(PROGRAMS) $(SLIB_FILE) pre-process.h sparse.pc
+
+dist:
+ @if test "`git describe`" != "$(VERSION)" ; then \
+ echo 'Update VERSION in the Makefile before running "make dist".' ; \
+ exit 1 ; \
+ fi
+ git archive --format=tar --prefix=sparse-$(VERSION)/ HEAD^{tree} | gzip -9 > sparse-$(VERSION).tar.gz