aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 12:25:12 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 17:03:37 +0100
commitd8149fa5f8d14d61ba2cc4c0b3469570281aac4a (patch)
treedb3293519d2a6f401f744a4a401558ec536f66e9 /dev-python
parentdev-python/astroscrappy: new dep (diff)
downloadsci-d8149fa5f8d14d61ba2cc4c0b3469570281aac4a.tar.gz
sci-d8149fa5f8d14d61ba2cc4c0b3469570281aac4a.tar.bz2
sci-d8149fa5f8d14d61ba2cc4c0b3469570281aac4a.zip
dev-python/ccdproc: bump EAPI, bump py targets
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ccdproc/Manifest1
-rw-r--r--dev-python/ccdproc/ccdproc-2.1.0.ebuild38
-rw-r--r--dev-python/ccdproc/ccdproc-9999.ebuild58
3 files changed, 39 insertions, 58 deletions
diff --git a/dev-python/ccdproc/Manifest b/dev-python/ccdproc/Manifest
new file mode 100644
index 000000000..8220136aa
--- /dev/null
+++ b/dev-python/ccdproc/Manifest
@@ -0,0 +1 @@
+DIST ccdproc-2.1.0.tar.gz 604227 BLAKE2B 0c570722b7efc15969c0887341721faa320ff6967a6f6bd218e56ec6f17ee13bc987c0d22a3d681ba51d85f0e51b532c7287fb77a6ad4ba799c3ca9d7f9ef5b7 SHA512 25fea4e3f750c70d4d952bf99c3846a0e7ec0ac22adf6fd9a3dfced5399ab3a40846396367abf397835a2f243b6a25e73baa9ef11861bb0374ccaaa5e4190ff6
diff --git a/dev-python/ccdproc/ccdproc-2.1.0.ebuild b/dev-python/ccdproc/ccdproc-2.1.0.ebuild
new file mode 100644
index 000000000..be1c00c5f
--- /dev/null
+++ b/dev-python/ccdproc/ccdproc-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astropy affiliated package for reducing optical/IR CCD data"
+HOMEPAGE="https://github.com/astropy/ccdproc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#TODO: Package all these pytest deps:
+# pytest-doctestplus>=0.2.0
+# pytest-remotedata>=0.3.1
+# pytest-openfiles>=0.3.1
+# pytest-astropy-header>=0.1.2
+# pytest-arraydiff>=0.1
+# pytest-filter-subpackage>=0.1
+RESTRICT="test"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ >=dev-python/astropy-2.0[${PYTHON_USEDEP}]
+ dev-python/astroscrappy[${PYTHON_USEDEP}]
+ dev-python/reproject[${PYTHON_USEDEP}]
+ sci-libs/scikit-image[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-astropy
+distutils_enable_tests pytest
diff --git a/dev-python/ccdproc/ccdproc-9999.ebuild b/dev-python/ccdproc/ccdproc-9999.ebuild
deleted file mode 100644
index c7a56c4e0..000000000
--- a/dev-python/ccdproc/ccdproc-9999.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/astropy/${PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Astropy affiliated package for reducing optical/IR CCD data"
-HOMEPAGE="https://github.com/astropy/ccdproc"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc"
-DOCS=( README.rst )
-
-RDEPEND="
- >=dev-python/astropy-0.4[${PYTHON_USEDEP}]
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- sed -e '/import ah_bootstrap/d' -i setup.py || die "Removing ah_bootstrap failed"
-}
-
-python_compile_all() {
- if use doc; then
- python_export_best
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}" || die
- "${EPYTHON}" -c "import ${PN}, sys;r = ${PN}.test(verbose=True);sys.exit(r)" \
- || die "tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}