summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2013-07-06 19:48:38 -0700
committerZac Medico <zmedico@gentoo.org>2013-07-06 19:48:38 -0700
commit1eee049e21caa96b4ef874723cd8ad43d331b979 (patch)
treea7da90992358b94607b0be652f1a329931d8feb4
parentdoebuild: fix fd_pipes support, bug #475812 (diff)
downloadportage-1eee049e21caa96b4ef874723cd8ad43d331b979.tar.gz
portage-1eee049e21caa96b4ef874723cd8ad43d331b979.tar.bz2
portage-1eee049e21caa96b4ef874723cd8ad43d331b979.zip
DoebuildFdPipesTestCase: fix docstring
-rw-r--r--pym/portage/tests/ebuild/test_doebuild_fd_pipes.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/pym/portage/tests/ebuild/test_doebuild_fd_pipes.py b/pym/portage/tests/ebuild/test_doebuild_fd_pipes.py
index 1a5177003..ddd73e2ba 100644
--- a/pym/portage/tests/ebuild/test_doebuild_fd_pipes.py
+++ b/pym/portage/tests/ebuild/test_doebuild_fd_pipes.py
@@ -22,14 +22,14 @@ class DoebuildProcess(ForkProcess):
return portage.doebuild(*self.doebuild_pargs, **self.doebuild_kwargs)
class DoebuildFdPipesTestCase(TestCase):
- """
- Invoke portage.package.ebuild.doebuild.spawn() with a
- minimal environment. This gives coverage to some of
- the ebuild execution internals, like ebuild.sh,
- AbstractEbuildProcess, and EbuildIpcDaemon.
- """
def testDoebuild(self):
+ """
+ Invoke portage.doebuild() with the fd_pipes parameter, and
+ check that the expected output appears in the pipe. This
+ functionality is not used by portage internally, but it is
+ supported for API consumers (see bug #475812).
+ """
ebuild_body = textwrap.dedent("""
S=${WORKDIR}