aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-21 17:24:33 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-21 20:41:16 +0300
commit817ba39b95c1598f59b49f5b599eb46b3fa074b9 (patch)
treedba5e108081f7e6cd500b77d93d446de42505d2a /testdata
parenttestdata: Use a more realistic python-any-r1 implementation (diff)
downloadpkgcheck-817ba39b95c1598f59b49f5b599eb46b3fa074b9.tar.gz
pkgcheck-817ba39b95c1598f59b49f5b599eb46b3fa074b9.tar.bz2
pkgcheck-817ba39b95c1598f59b49f5b599eb46b3fa074b9.zip
testdata: Add pypy3 to PYTHON_COMPAT in test ebuilds
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'testdata')
-rw-r--r--testdata/data/repos/python/PythonCheck/DistutilsNonPEP517Build/fix.patch2
-rw-r--r--testdata/repos/python/PythonCheck/DistutilsNonPEP517Build/DistutilsNonPEP517Build-0.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-0.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-1.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-0.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-1.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-2.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonHasVersionMissingPythonUseDep/PythonHasVersionMissingPythonUseDep-0.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-0.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-1.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-0.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-1.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-2.ebuild2
-rw-r--r--testdata/repos/python/PythonCheck/PythonMissingSCMDependency/PythonMissingSCMDependency-0.ebuild2
-rw-r--r--testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild6
-rw-r--r--testdata/repos/python/eclass/python-any-r1.eclass13
-rw-r--r--testdata/repos/python/eclass/python-r1.eclass13
-rw-r--r--testdata/repos/python/eclass/python-single-r1.eclass13
18 files changed, 50 insertions, 23 deletions
diff --git a/testdata/data/repos/python/PythonCheck/DistutilsNonPEP517Build/fix.patch b/testdata/data/repos/python/PythonCheck/DistutilsNonPEP517Build/fix.patch
index 6ad28c31..d4e50d37 100644
--- a/testdata/data/repos/python/PythonCheck/DistutilsNonPEP517Build/fix.patch
+++ b/testdata/data/repos/python/PythonCheck/DistutilsNonPEP517Build/fix.patch
@@ -5,6 +5,6 @@ diff -Naur python/PythonCheck/DistutilsNonPEP517Build/DistutilsNonPEP517Build-0.
EAPI=7
+DISTUTILS_USE_PEP517=setuptools
- PYTHON_COMPAT=( python3_10 )
+ PYTHON_COMPAT=( pypy3 python3_10 )
inherit distutils-r1
diff --git a/testdata/repos/python/PythonCheck/DistutilsNonPEP517Build/DistutilsNonPEP517Build-0.ebuild b/testdata/repos/python/PythonCheck/DistutilsNonPEP517Build/DistutilsNonPEP517Build-0.ebuild
index 03ff2937..d2e833ec 100644
--- a/testdata/repos/python/PythonCheck/DistutilsNonPEP517Build/DistutilsNonPEP517Build-0.ebuild
+++ b/testdata/repos/python/PythonCheck/DistutilsNonPEP517Build/DistutilsNonPEP517Build-0.ebuild
@@ -1,6 +1,6 @@
EAPI=7
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit distutils-r1
diff --git a/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-0.ebuild b/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-0.ebuild
index a70a4d3e..9a6a57ee 100644
--- a/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-0.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-1.ebuild b/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-1.ebuild
index 2652cf8c..bd81efe2 100644
--- a/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-1.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonAnyMismatchedDepHasVersionCheck/PythonAnyMismatchedDepHasVersionCheck-1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-0.ebuild b/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-0.ebuild
index e1b1c707..3279e62b 100644
--- a/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-0.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-1.ebuild b/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-1.ebuild
index 616bcd95..48c00f4d 100644
--- a/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-1.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-2.ebuild b/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-2.ebuild
index 0f011b36..27e72e88 100644
--- a/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-2.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonAnyMismatchedUseHasVersionCheck/PythonAnyMismatchedUseHasVersionCheck-2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonHasVersionMissingPythonUseDep/PythonHasVersionMissingPythonUseDep-0.ebuild b/testdata/repos/python/PythonCheck/PythonHasVersionMissingPythonUseDep/PythonHasVersionMissingPythonUseDep-0.ebuild
index 24ebb878..5e5ff7f3 100644
--- a/testdata/repos/python/PythonCheck/PythonHasVersionMissingPythonUseDep/PythonHasVersionMissingPythonUseDep-0.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonHasVersionMissingPythonUseDep/PythonHasVersionMissingPythonUseDep-0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-0.ebuild b/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-0.ebuild
index face1460..02ef25e0 100644
--- a/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-0.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-1.ebuild b/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-1.ebuild
index 240f5364..87ff6224 100644
--- a/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-1.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonHasVersionUsage/PythonHasVersionUsage-1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit python-any-r1
diff --git a/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-0.ebuild b/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-0.ebuild
index 236182e9..1b5b1fd4 100644
--- a/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-0.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-0.ebuild
@@ -1,5 +1,5 @@
EAPI=7
-PYTHON_COMPAT=( python3_9 )
+PYTHON_COMPAT=( pypy3 python3_9 )
inherit python-r1
diff --git a/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-1.ebuild b/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-1.ebuild
index 5c2d85fb..191d4974 100644
--- a/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-1.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-1.ebuild
@@ -2,7 +2,7 @@ EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit distutils-r1
diff --git a/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-2.ebuild b/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-2.ebuild
index 73d59a27..60c7b3df 100644
--- a/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-2.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonMissingDeps/PythonMissingDeps-2.ebuild
@@ -2,7 +2,7 @@ EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit distutils-r1
diff --git a/testdata/repos/python/PythonCheck/PythonMissingSCMDependency/PythonMissingSCMDependency-0.ebuild b/testdata/repos/python/PythonCheck/PythonMissingSCMDependency/PythonMissingSCMDependency-0.ebuild
index 79a8a8df..f793e70e 100644
--- a/testdata/repos/python/PythonCheck/PythonMissingSCMDependency/PythonMissingSCMDependency-0.ebuild
+++ b/testdata/repos/python/PythonCheck/PythonMissingSCMDependency/PythonMissingSCMDependency-0.ebuild
@@ -1,7 +1,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( pypy3 python3_10 )
inherit distutils-r1
diff --git a/testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild b/testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild
new file mode 100644
index 00000000..5c7e964e
--- /dev/null
+++ b/testdata/repos/python/dev-python/pypy3/pypy-7.3.17.ebuild
@@ -0,0 +1,6 @@
+EAPI=8
+
+DESCRIPTION="Stub ebuild for pypy3 interpreter"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+LICENSE="BSD"
+SLOT="0/pypy310"
diff --git a/testdata/repos/python/eclass/python-any-r1.eclass b/testdata/repos/python/eclass/python-any-r1.eclass
index 8cfc2f5c..68c9774c 100644
--- a/testdata/repos/python/eclass/python-any-r1.eclass
+++ b/testdata/repos/python/eclass/python-any-r1.eclass
@@ -14,9 +14,16 @@ _python_set_impls() {
local i slot
PYTHON_DEPS="|| ("
for i in "${PYTHON_COMPAT[@]}"; do
- slot=${i#python}
- slot=${slot/_/.}
- PYTHON_DEPS+=" dev-lang/python:${slot}"
+ case ${i} in
+ python*)
+ slot=${i#python}
+ slot=${slot/_/.}
+ PYTHON_DEPS+=" dev-lang/python:${slot}"
+ ;;
+ pypy3)
+ PYTHON_DEPS+=" dev-python/pypy3:="
+ ;;
+ esac
done
PYTHON_DEPS+=" )"
PYTHON_REQUIRED_USE='I-DO-NOT-EXIST-IN-PYTHON-ANY-R1'
diff --git a/testdata/repos/python/eclass/python-r1.eclass b/testdata/repos/python/eclass/python-r1.eclass
index 9646b3a3..e33047ca 100644
--- a/testdata/repos/python/eclass/python-r1.eclass
+++ b/testdata/repos/python/eclass/python-r1.eclass
@@ -14,10 +14,17 @@ _python_set_impls() {
local i slot
local -a use
for i in "${PYTHON_COMPAT[@]}"; do
- slot=${i#python}
- slot=${slot/_/.}
use+=( "python_targets_${i}" )
- PYTHON_DEPS+=" python_targets_${i}? ( dev-lang/python:${slot} )"
+ case ${i} in
+ python*)
+ slot=${i#python}
+ slot=${slot/_/.}
+ PYTHON_DEPS+=" python_targets_${i}? ( dev-lang/python:${slot} )"
+ ;;
+ pypy3)
+ PYTHON_DEPS+=" python_targets_${i}? ( dev-python/pypy3:= )"
+ ;;
+ esac
done
IUSE+=" ${use[@]}"
PYTHON_REQUIRED_USE="|| ( ${use[@]} )"
diff --git a/testdata/repos/python/eclass/python-single-r1.eclass b/testdata/repos/python/eclass/python-single-r1.eclass
index e16b8a93..a7049ac0 100644
--- a/testdata/repos/python/eclass/python-single-r1.eclass
+++ b/testdata/repos/python/eclass/python-single-r1.eclass
@@ -14,10 +14,17 @@ _python_set_impls() {
local i slot
local -a use use_deps
for i in "${PYTHON_COMPAT[@]}"; do
- slot=${i#python}
- slot=${slot/_/.}
use+=( "python_single_target_${i}" )
- PYTHON_DEPS+=" python_single_target_${i}? ( dev-lang/python:${slot} )"
+ case ${i} in
+ python*)
+ slot=${i#python}
+ slot=${slot/_/.}
+ PYTHON_DEPS+=" python_single_target_${i}? ( dev-lang/python:${slot} )"
+ ;;
+ pypy3)
+ PYTHON_DEPS+=" python_single_target_${i}? ( dev-python/pypy3:= )"
+ ;;
+ esac
done
IUSE+=" ${use[@]}"
PYTHON_REQUIRED_USE="^^ ( ${use[@]} )"