summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@lavabit.com>2013-02-27 12:48:53 -0500
committerBrian Evans <grknight@lavabit.com>2013-02-27 12:48:53 -0500
commitf15bfea3c776a0feee358c29ffa0859b75ba9ed7 (patch)
treecd27e8cce2762251b65c3f23a53c8d892c2aafac
parentPort 20002_all_mysql-va-list.patch for 5.6. (diff)
downloadmysql-extras-f15bfea3c776a0feee358c29ffa0859b75ba9ed7.tar.gz
mysql-extras-f15bfea3c776a0feee358c29ffa0859b75ba9ed7.tar.bz2
mysql-extras-f15bfea3c776a0feee358c29ffa0859b75ba9ed7.zip
Fix bad CMake references to zlib and readline in 5.6mysql-extras-20130304-1907Z
-rw-r--r--00000_index.txt5
-rw-r--r--20003_all_fix-5.6-library.patch26
2 files changed, 31 insertions, 0 deletions
diff --git a/00000_index.txt b/00000_index.txt
index 5829392..25a2422 100644
--- a/00000_index.txt
+++ b/00000_index.txt
@@ -1466,3 +1466,8 @@
@ver 5.06.00.00 to 5.99.99.99
@pn mysql
@@ Bug 442000, upstream 62729 compilation failure on arm and possibly other arches where va_list is a struct or array.
+
+@patch 20003_all_fix-5.6-library.patch
+@ver 5.06.00.00 to 5.99.99.99
+@pn mysql
+@@ Fix bad references to zlib and readline upstream bugs 68277 and 68087
diff --git a/20003_all_fix-5.6-library.patch b/20003_all_fix-5.6-library.patch
new file mode 100644
index 0000000..ab207e5
--- /dev/null
+++ b/20003_all_fix-5.6-library.patch
@@ -0,0 +1,26 @@
+--- mysql-5.6-5.6.9-rc+dfsg.orig/cmake/readline.cmake
++++ mysql-5.6-5.6.9-rc+dfsg/cmake/readline.cmake
+@@ -192,9 +192,9 @@ MACRO (MYSQL_CHECK_READLINE)
+ IF(WITH_LIBEDIT)
+ MYSQL_USE_BUNDLED_LIBEDIT()
+ ELSE()
+- FIND_SYSTEM_LIBEDIT(edit)
+- IF(NOT_LIBEDIT_FOUND)
+- MESSAGE(FATAL_ERROR "Cannot find system libedit libraries.Use WITH_LIBEDIT")
++ FIND_SYSTEM_LIBEDIT(readline)
++ IF(NOT_LIBREADLINE_FOUND)
++ MESSAGE(FATAL_ERROR "Cannot find system libreadline libraries.Use WITH_LIBREADLINE")
+ ENDIF()
+ ENDIF()
+ ENDIF(NOT WIN32)
+--- a/storage/perfschema/unittest/CMakeLists.txt 2013-02-27 10:45:29.559846643 -0500
++++ b/storage/perfschema/unittest/CMakeLists.txt 2013-02-27 10:45:59.459430483 -0500
+@@ -63,7 +63,7 @@
+ TARGET_LINK_LIBRARIES(pfs_connect_attr-t sql binlog rpl master slave sql)
+ TARGET_LINK_LIBRARIES(pfs_connect_attr-t mysys mysys_ssl)
+ TARGET_LINK_LIBRARIES(pfs_connect_attr-t vio ${SSL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(pfs_connect_attr-t strings dbug regex mysys zlib)
++TARGET_LINK_LIBRARIES(pfs_connect_attr-t strings dbug regex mysys ${ZLIB_LIBRARY})
+ ADD_TEST(pfs_connect_attr pfs_connect_attr-t)
+
+ # On windows, pfs_connect_attr-t may depend on openssl dlls.