summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-03-25 13:56:52 -0400
committerMike Pagano <mpagano@gentoo.org>2020-03-25 13:56:52 -0400
commitbebe7c804f5e05b95f2afcdc28cea99e41621d09 (patch)
tree2f847225fbbbd2add88a42e6095db777242e057f
parentLinux patch 5.5.12 (diff)
downloadlinux-patches-bebe7c804f5e05b95f2afcdc28cea99e41621d09.tar.gz
linux-patches-bebe7c804f5e05b95f2afcdc28cea99e41621d09.tar.bz2
linux-patches-bebe7c804f5e05b95f2afcdc28cea99e41621d09.zip
Linux patch 5.5.135.5-15
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1012_linux-5.5.13.patch57
2 files changed, 61 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 1bae1b32..c561f7c8 100644
--- a/0000_README
+++ b/0000_README
@@ -91,6 +91,10 @@ Patch: 1011_linux-5.5.12.patch
From: http://www.kernel.org
Desc: Linux 5.5.12
+Patch: 1012_linux-5.5.13.patch
+From: http://www.kernel.org
+Desc: Linux 5.5.13
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1012_linux-5.5.13.patch b/1012_linux-5.5.13.patch
new file mode 100644
index 00000000..47908a3c
--- /dev/null
+++ b/1012_linux-5.5.13.patch
@@ -0,0 +1,57 @@
+diff --git a/Makefile b/Makefile
+index d962fe0f26ce..d1574c99f83c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 5
+-SUBLEVEL = 12
++SUBLEVEL = 13
+ EXTRAVERSION =
+ NAME = Kleptomaniac Octopus
+
+diff --git a/drivers/base/core.c b/drivers/base/core.c
+index 3306d5ae92a6..dbb0f9130f42 100644
+--- a/drivers/base/core.c
++++ b/drivers/base/core.c
+@@ -718,6 +718,8 @@ static void __device_links_queue_sync_state(struct device *dev,
+ {
+ struct device_link *link;
+
++ if (!dev_has_sync_state(dev))
++ return;
+ if (dev->state_synced)
+ return;
+
+@@ -819,7 +821,7 @@ late_initcall(sync_state_resume_initcall);
+
+ static void __device_links_supplier_defer_sync(struct device *sup)
+ {
+- if (list_empty(&sup->links.defer_sync))
++ if (list_empty(&sup->links.defer_sync) && dev_has_sync_state(sup))
+ list_add_tail(&sup->links.defer_sync, &deferred_sync);
+ }
+
+diff --git a/include/linux/device.h b/include/linux/device.h
+index 96ff76731e93..50d97767d8d6 100644
+--- a/include/linux/device.h
++++ b/include/linux/device.h
+@@ -1522,6 +1522,17 @@ static inline struct device_node *dev_of_node(struct device *dev)
+
+ void driver_init(void);
+
++static inline bool dev_has_sync_state(struct device *dev)
++{
++ if (!dev)
++ return false;
++ if (dev->driver && dev->driver->sync_state)
++ return true;
++ if (dev->bus && dev->bus->sync_state)
++ return true;
++ return false;
++}
++
+ /*
+ * High level routines for use by the bus drivers
+ */