summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2009-02-26 13:58:35 +0000
committerDaniel Veillard <veillard@redhat.com>2009-02-26 13:58:35 +0000
commita7868e0131516ef2dece82586edd52dc87fe336c (patch)
tree1c8b683d987daca0295957a00720ade048e5bdef /python
parentdocumenting static host IP assignments (diff)
downloadlibvirt-a7868e0131516ef2dece82586edd52dc87fe336c.tar.gz
libvirt-a7868e0131516ef2dece82586edd52dc87fe336c.tar.bz2
libvirt-a7868e0131516ef2dece82586edd52dc87fe336c.zip
* python/Makefile.am: avoid a parallel make issue #472702
provided by Michael Marineau Daniel
Diffstat (limited to 'python')
-rw-r--r--python/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 8d1462b3f..a7c342e7c 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -51,8 +51,11 @@ GENERATED= libvirt-export.c \
libvirt-py.h \
libvirtclass.py
-$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
+generated.stamp: $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
+ touch $@
+
+$(GENERATED): generated.stamp
libvirt.py: $(srcdir)/libvir.py $(GENERATED) $(CLASSES_EXTRA)
cat $(srcdir)/libvir.py libvirtclass.py > $@-t
@@ -70,7 +73,7 @@ install-data-local:
uninstall-local:
rm -f $(DESTDIR)$(pythondir)/libvirt.py
-CLEANFILES= $(GENERATED) libvirt.py
+CLEANFILES= $(GENERATED) generated.stamp libvirt.py
else
all: