summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2006-02-23 11:26:17 +0000
committerDaniel Veillard <veillard@redhat.com>2006-02-23 11:26:17 +0000
commit97f95666873a0bd44fd0c7c92dfbed11c304cee4 (patch)
treee29afd1ee4cc2a544eca4a9a955cb7a9b12d5026 /python/generator.py
parent* NEWS configure.in docs/libvir.html docs/news.html: preparing the (diff)
downloadlibvirt-97f95666873a0bd44fd0c7c92dfbed11c304cee4.tar.gz
libvirt-97f95666873a0bd44fd0c7c92dfbed11c304cee4.tar.bz2
libvirt-97f95666873a0bd44fd0c7c92dfbed11c304cee4.zip
* src/libvirt.c: fixing a bug before the release of 0.0.5
* python/generator.py python/libvir.c python/libvirt-python-api.xml: also fixing the binding for getting a domain UUID * python/tests/Makefile.am python/tests/uuid.py: added a test for the new UUID API Daniel
Diffstat (limited to 'python/generator.py')
-rwxr-xr-xpython/generator.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/generator.py b/python/generator.py
index c336f6114..d9fa80914 100755
--- a/python/generator.py
+++ b/python/generator.py
@@ -203,7 +203,9 @@ def enum(type, name, value):
#######################################################################
functions_failed = []
-functions_skipped = []
+functions_skipped = [
+ "virConnectListDomains" , "virDomainGetUUID"
+]
skipped_modules = {
}
@@ -259,6 +261,7 @@ foreign_encoding_args = (
skip_impl = (
'virConnectListDomainsID',
'virDomainGetInfo',
+ 'virDomainGetUUID',
)
def skip_function(name):
@@ -568,6 +571,8 @@ def nameFixup(name, classe, type, file):
func = name
if func == "iD":
func = "ID"
+ if func == "uUID":
+ func = "UUID"
if func == "oSType":
func = "OSType"
if func == "xMLDesc":