summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-11-25 15:34:59 +0000
committerJim Meyering <meyering@redhat.com>2008-11-25 15:34:59 +0000
commitd5ae2c8882990922158920d9005510a429ed9435 (patch)
tree72feaf5b80939d5d9c1eb4be587cfe5de26f7092
parentDisable UML driver on mingw RPM build (diff)
downloadlibvirt-d5ae2c8882990922158920d9005510a429ed9435.tar.gz
libvirt-d5ae2c8882990922158920d9005510a429ed9435.tar.bz2
libvirt-d5ae2c8882990922158920d9005510a429ed9435.zip
don't silently skip a test
* tests/Makefile.am (EXTRA_DIST): Distribute domainschemadata/. * tests/domainschematest: Fail the test if find invocation fails.
-rw-r--r--ChangeLog6
-rw-r--r--tests/Makefile.am3
-rwxr-xr-xtests/domainschematest2
3 files changed, 9 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 19a955965..35d7834c6 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+Tue Nov 25 16:34:09 +0100 2008 Jim Meyering <meyering@redhat.com>
+
+ don't silently skip a test
+ * tests/Makefile.am (EXTRA_DIST): Distribute domainschemadata/.
+ * tests/domainschematest: Fail the test if find invocation fails.
+
Tue Nov 25 11:27:40 GMT 2008 Daniel P. Berrange <berrange@redhat.com>
* mingw32-libvirt.spec.in: Disable UML driver for mingw build
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9752cbf69..fd319e11a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,7 +41,8 @@ EXTRA_DIST = \
xmlrpcserver.py \
qemuxml2argvdata \
nodeinfodata \
- domainschematest
+ domainschematest \
+ domainschemadata
noinst_PROGRAMS = xmlrpctest virshtest conftest \
nodeinfotest statstest qparamtest
diff --git a/tests/domainschematest b/tests/domainschematest
index c841c869e..d85d4631b 100755
--- a/tests/domainschematest
+++ b/tests/domainschematest
@@ -8,7 +8,7 @@ n=0
f=0
for dir in $DOMAINDIRS
do
- XML=`find $abs_srcdir/$dir -name '*.xml'`
+ XML=`find $abs_srcdir/$dir -name '*.xml'` || exit 1
for xml in $XML
do