diff options
author | Eric Blake <eblake@redhat.com> | 2012-08-16 16:18:44 -0600 |
---|---|---|
committer | Eric Blake <eblake@redhat.com> | 2012-08-16 16:37:27 -0600 |
commit | ca9be83de9d33d31d291cd4236457a83f0545809 (patch) | |
tree | 9e598bdf08a93dc1ad644498fc52d68247f24320 | |
parent | build: ship stamp files (diff) | |
download | libvirt-ca9be83de9d33d31d291cd4236457a83f0545809.tar.gz libvirt-ca9be83de9d33d31d291cd4236457a83f0545809.tar.bz2 libvirt-ca9be83de9d33d31d291cd4236457a83f0545809.zip |
build: fix syntax check during 'make distcheck'
'make distcheck' was failing because a syntax check file,
.sc-start-sc_vulnerable_makefile_CVE-2012-3386, got left
behind. I traced it to the 'distdir' rule depending on a
shortcut syntax-check name rather than the full rule name
normally used during 'local-check' from maint.mk.
* cfg.mk (distdir): Depend on full rule, not shorthand name.
-rw-r--r-- | cfg.mk | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -85,7 +85,7 @@ local-checks-to-skip = \ ifeq ($(filter dist%, $(MAKECMDGOALS)), ) local-checks-to-skip += sc_vulnerable_makefile_CVE-2012-3386 else -distdir: sc_vulnerable_makefile_CVE-2012-3386 +distdir: sc_vulnerable_makefile_CVE-2012-3386.z endif # Files that should never cause syntax check failures. |