aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorscarabeus <scarabeus@gentoo.org>2010-11-17 02:25:46 +0000
committerscarabeus <scarabeus@gentoo.org>2010-11-17 02:25:46 +0000
commitf5a8d22d95088917aa2ef17c87dcf474e25e21de (patch)
treea6e3af052417ede2dfb6f38036a6e8e6b69d3ed9
parentChange keywords short option to 'y' from 'k' which was already taken by the c... (diff)
downloadgentoolkit-f5a8d22d95088917aa2ef17c87dcf474e25e21de.tar.gz
gentoolkit-f5a8d22d95088917aa2ef17c87dcf474e25e21de.tar.bz2
gentoolkit-f5a8d22d95088917aa2ef17c87dcf474e25e21de.zip
Respect category when running as cwd call without specified package.
svn path=/trunk/gentoolkit/; revision=853
-rw-r--r--pym/gentoolkit/eshowkw/__init__.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/pym/gentoolkit/eshowkw/__init__.py b/pym/gentoolkit/eshowkw/__init__.py
index 72be2f1..cb957a3 100644
--- a/pym/gentoolkit/eshowkw/__init__.py
+++ b/pym/gentoolkit/eshowkw/__init__.py
@@ -112,13 +112,13 @@ def main(argv, indirect = False):
map(lambda x: process_display(x, keywords, dbapi), package)
else:
currdir = os.getcwd()
- package=os.path.basename(currdir)
# check if there are actualy some ebuilds
ebuilds = ['%s' % x for x in os.listdir(currdir)
if fnmatch.fnmatch(x, '*.ebuild')]
if len(ebuilds) <= 0:
msg_err = 'No ebuilds at "%s"' % currdir
raise SystemExit(msg_err)
+ package= '%s/%s' % (os.path.basename(os.path.abspath('../')), os.path.basename(currdir))
ourtree = os.path.abspath('../../')
overlays = '%s %s' % (ports['PORTDIR_OVERLAY'], ourtree)
mysettings = portc(env={'PORTDIR_OVERLAY': overlays})