diff options
author | Alexandre Vassalotti <alexandre@peadrop.com> | 2008-06-12 18:26:05 +0000 |
---|---|---|
committer | Alexandre Vassalotti <alexandre@peadrop.com> | 2008-06-12 18:26:05 +0000 |
commit | ca2d610dba5711823999c4751897160f138a7811 (patch) | |
tree | 2f1e8b2a6c3205c21dcf26ba74787826ed02c59f /setup.py | |
parent | Fixed test_urllib2 by coercing Message object to str (diff) | |
download | cpython-ca2d610dba5711823999c4751897160f138a7811.tar.gz cpython-ca2d610dba5711823999c4751897160f138a7811.tar.bz2 cpython-ca2d610dba5711823999c4751897160f138a7811.zip |
Restore _pickle module accelerator module.
Removed Windows support temporarily.
64bit bug with integer unpickling is now fixed.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -422,6 +422,9 @@ class PyBuildExt(build_ext): exts.append( Extension("_functools", ["_functoolsmodule.c"]) ) # Memory-based IO accelerator modules exts.append( Extension("_bytesio", ["_bytesio.c"]) ) + exts.append( Extension("_stringio", ["_stringio.c"]) ) + # C-optimized pickle replacement + exts.append( Extension("_pickle", ["_pickle.c"]) ) # atexit exts.append( Extension("atexit", ["atexitmodule.c"]) ) # _json speedups |