aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2020-06-09 06:54:54 -0700
committerGitHub <noreply@github.com>2020-06-09 06:54:54 -0700
commit6cb24a035c5980cab39b6dc5d70762af07293bea (patch)
treeddb6889a2956a464206dd24c03b48c79aa4c0a13 /configure.ac
parentRemove reference to 3.7 and 3.8 backports. (GH-20754) (#20755) (diff)
downloadcpython-6cb24a035c5980cab39b6dc5d70762af07293bea.tar.gz
cpython-6cb24a035c5980cab39b6dc5d70762af07293bea.tar.bz2
cpython-6cb24a035c5980cab39b6dc5d70762af07293bea.zip
bpo-40684: Fix make install for platlibdir=lib64 (GH-20736)
"make install" now uses the PLATLIBDIR variable for the destination lib-dynload/ directory when ./configure --with-platlibdir is used. Update --with-platlibdir comment in configure. (cherry picked from commit 51ae31e5b93b986e57a7e18e25f981a6ffcdefb7) Co-authored-by: Victor Stinner <vstinner@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d63198c7b1..bb327f68eb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4770,7 +4770,11 @@ else
fi
-# Check for --with-libdir-name
+AC_SUBST(BINLIBDEST)
+BINLIBDEST='$(LIBDIR)/python$(VERSION)'
+
+
+# Check for --with-platlibdir
# /usr/$LIDIRNAME/python$VERSION
AC_SUBST(PLATLIBDIR)
PLATLIBDIR="lib"
@@ -4787,6 +4791,7 @@ if test -n "$withval" -a "$withval" != yes -a "$withval" != no
then
AC_MSG_RESULT(yes)
PLATLIBDIR="$withval"
+ BINLIBDEST='${exec_prefix}/${PLATLIBDIR}/python$(VERSION)'
else
AC_MSG_RESULT(no)
fi],