aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-10-11 13:50:03 -0400
committerMike Gilbert <floppym@gentoo.org>2021-10-11 15:20:09 -0400
commitc8bbbdcdb1e129c55df13c95a6355bad87a1ad5f (patch)
tree3b88c29e821c9977640399f3089c097ecb41bf76
parentcloses bpo-44751: Move crypt.h include from public header to _cryptmodule (GH... (diff)
downloadcpython-c8bbbdcdb1e129c55df13c95a6355bad87a1ad5f.tar.gz
cpython-c8bbbdcdb1e129c55df13c95a6355bad87a1ad5f.tar.bz2
cpython-c8bbbdcdb1e129c55df13c95a6355bad87a1ad5f.zip
bpo-45433: Do not link libpython against libcryptgentoo-3.10.0_p1
Save/restore LIBS when calling AC_SEARCH_LIBS(..., crypt). This avoid linking libpython with libcrypt.
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e6c07c2793..2379c7c9f17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4029,6 +4029,8 @@ AC_CHECK_FUNCS(setpgrp,
# We search for both crypt and crypt_r as one or the other may be defined
# This gets us our -lcrypt in LIBS when required on the target platform.
+# Save/restore LIBS to avoid linking libpython with libcrypt.
+LIBS_SAVE=$LIBS
AC_SEARCH_LIBS(crypt, crypt)
AC_SEARCH_LIBS(crypt_r, crypt)
@@ -4043,6 +4045,7 @@ char *r = crypt_r("", "", &d);
[AC_DEFINE(HAVE_CRYPT_R, 1, [Define if you have the crypt_r() function.])],
[])
)
+LIBS=$LIBS_SAVE
AC_CHECK_FUNCS(clock_gettime, [], [
AC_CHECK_LIB(rt, clock_gettime, [