summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2008-10-29 00:03:25 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2008-10-29 00:03:25 +0900
commite2a64648d9f5a0ee6e6334763c56d52c815926ad (patch)
tree06cd537ff613cfb10442a9347c5fc26dfda55b44 /net-www
parentAdded net-wireless/broadcom-sta and netwireless/ndiswrapper for DELL Inspiron... (diff)
downloadmatsuu-e2a64648d9f5a0ee6e6334763c56d52c815926ad.tar.gz
matsuu-e2a64648d9f5a0ee6e6334763c56d52c815926ad.tar.bz2
matsuu-e2a64648d9f5a0ee6e6334763c56d52c815926ad.zip
Removed subdirectories.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/google-gears/Manifest7
-rw-r--r--net-www/google-gears/files/digest-google-gears-99990
-rw-r--r--net-www/google-gears/google-gears-9999.ebuild65
3 files changed, 72 insertions, 0 deletions
diff --git a/net-www/google-gears/Manifest b/net-www/google-gears/Manifest
new file mode 100644
index 0000000..6a1e9e3
--- /dev/null
+++ b/net-www/google-gears/Manifest
@@ -0,0 +1,7 @@
+EBUILD google-gears-9999.ebuild 1572 RMD160 ecde6e2f070c3675f35e7d6185ec4dfa0e8c9163 SHA1 0f6193a70b8a267c38deefb00ba4209805ba53bf SHA256 5dd9ff206e0cb08c8fd3ebdedf2ae02f439b3dec3552f44bb82557e2e54cd019
+MD5 5bae73309e32967ff6b7846edb75395e google-gears-9999.ebuild 1572
+RMD160 ecde6e2f070c3675f35e7d6185ec4dfa0e8c9163 google-gears-9999.ebuild 1572
+SHA256 5dd9ff206e0cb08c8fd3ebdedf2ae02f439b3dec3552f44bb82557e2e54cd019 google-gears-9999.ebuild 1572
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-google-gears-9999 0
+RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-google-gears-9999 0
+SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-google-gears-9999 0
diff --git a/net-www/google-gears/files/digest-google-gears-9999 b/net-www/google-gears/files/digest-google-gears-9999
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/net-www/google-gears/files/digest-google-gears-9999
diff --git a/net-www/google-gears/google-gears-9999.ebuild b/net-www/google-gears/google-gears-9999.ebuild
new file mode 100644
index 0000000..2372182
--- /dev/null
+++ b/net-www/google-gears/google-gears-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion mozextension multilib
+
+ESVN_REPO_URI="http://google-gears.googlecode.com/svn/trunk/gears"
+
+DESCRIPTION="Google Gears"
+HOMEPAGE="http://code.google.com/p/google-gears/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="www-client/mozilla-firefox
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/gears"
+
+MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+
+ local myarch="i386"
+
+ if ! use x86 ; then
+ myarch="$(uname -m)"
+ fi
+
+ sed -i \
+ -e "/ARCH = /s:i386:${myarch}:" \
+ -e "s:gcc:$(tc-getCC):" \
+ -e "s:g++:$(tc-getCXX):" \
+ -e "/^GECKO_SDK = /s:=.*:= ${MOZILLA_FIVE_HOME}:" \
+ -e "/^FF_CPPFLAGS = /s:$: $(pkg-config firefox-xpcom --cflags) -I${MOZILLA_FIVE_HOME}/include/dom -I${MOZILLA_FIVE_HOME}/include/necko:" \
+ -e "/^FF_LIBS = /s:-lxpcomglue_s:$(pkg-config firefox-xpcom --libs):" \
+ -e "s:\(\$(GECKO_SDK)\)/\(bin\|lib\):\1:" \
+ -e "/^COMPILE_FLAGS_opt = /s:-O2:${CFLAGS}:" \
+ -e "/^COMPILE_FLAGS = /s:-Werror::" \
+ -e "s:gecko_sdk/bin/xpidl:xpidl:" \
+ tools/{config,rules}.mk || die
+
+ sed -i -e "/OnListenerEvent/s:<int>:<long>:" \
+ localserver/firefox/async_task_ff.cc || die
+
+ if ! use x86 ; then
+ sed -i -e "s/x86/${myarch}/g" base/firefox/install.rdf.m4 || die
+ fi
+
+ if ! use debug ; then
+ sed -i -e "/^MODE = /s|dbg|opt|" tools/config.mk || die
+ fi
+}
+
+src_install() {
+ xpi_install "${S}"/bin-*/installers/gears-*/
+
+ dohtml -r sdk
+}