summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--hardened/toolchain/eclass/toolchain.eclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/hardened/toolchain/eclass/toolchain.eclass b/hardened/toolchain/eclass/toolchain.eclass
index 2420907..2b0ceaf 100644
--- a/hardened/toolchain/eclass/toolchain.eclass
+++ b/hardened/toolchain/eclass/toolchain.eclass
@@ -2157,6 +2157,9 @@ do_gcc_PIE_patches() {
# adds non-default pie support (rs6000)
EPATCH_MULTI_MSG="Applying non-default pie patches ..." \
epatch "${WORKDIR}"/piepatch/nondef
+ # Force crt{begin,end}.o to be built normally
+ sed -e 's/^CRTSTUFF_T_CFLAGS =/CRTSTUFF_T_CFLAGS = -fno-PIE/' \
+ -i "${S}"/gcc/Makefile.in
# adds default pie support (rs6000 too) if DEFAULT_PIE[_SSP] is defined
want_minispecs ||
EPATCH_MULTI_MSG="Applying default pie patches ..." \