From 997d74c7577c49938d4a7cba50da4f8e95fffe04 Mon Sep 17 00:00:00 2001
From: Stefan Schweizer <genstef@gentoo.org>
Date: Thu, 23 Nov 2006 21:02:08 +0000
Subject: version bump (Portage version: 2.1.2_rc2-r1)

---
 sys-apps/list/ChangeLog               |  8 ++++-
 sys-apps/list/files/digest-list-2.0.0 |  3 ++
 sys-apps/list/list-2.0.0.ebuild       | 62 +++++++++++++++++++++++++++++++++++
 3 files changed, 72 insertions(+), 1 deletion(-)
 create mode 100644 sys-apps/list/files/digest-list-2.0.0
 create mode 100644 sys-apps/list/list-2.0.0.ebuild

(limited to 'sys-apps/list')

diff --git a/sys-apps/list/ChangeLog b/sys-apps/list/ChangeLog
index e6ebb4359276..a78322831060 100644
--- a/sys-apps/list/ChangeLog
+++ b/sys-apps/list/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/list
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/list/ChangeLog,v 1.7 2006/10/07 19:46:01 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/list/ChangeLog,v 1.8 2006/11/23 21:02:08 genstef Exp $
+
+*list-2.0.0 (23 Nov 2006)
+
+  23 Nov 2006; Stefan Schweizer <genstef@gentoo.org> -list-1.9.93.ebuild,
+  +list-2.0.0.ebuild:
+  version bump
 
   07 Oct 2006; Stefan Schweizer <genstef@gentoo.org> -list-1.9.92.ebuild:
   remove old
diff --git a/sys-apps/list/files/digest-list-2.0.0 b/sys-apps/list/files/digest-list-2.0.0
new file mode 100644
index 000000000000..84e450c44c5f
--- /dev/null
+++ b/sys-apps/list/files/digest-list-2.0.0
@@ -0,0 +1,3 @@
+MD5 7f1de1cf01eda3892f0aec254bd6b58e LiSt-2.0.0.tar.bz2 26889
+RMD160 b3f17a643c493e770ffc74d643b24967bbb7ccc7 LiSt-2.0.0.tar.bz2 26889
+SHA256 4e3dba8a48e7a5e3bb140d35b5d99ab54fcb75f89983c8a98867890cd793d16f LiSt-2.0.0.tar.bz2 26889
diff --git a/sys-apps/list/list-2.0.0.ebuild b/sys-apps/list/list-2.0.0.ebuild
new file mode 100644
index 000000000000..2ba46d3b0322
--- /dev/null
+++ b/sys-apps/list/list-2.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2005-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/list/list-2.0.0.ebuild,v 1.1 2006/11/23 21:02:08 genstef Exp $
+
+
+inherit eutils
+
+DESCRIPTION="Python client from www.linux-stats.org to collect your hardware and to generate statistics about linux-systems."
+HOMEPAGE="http://www.linux-stats.org/"
+SRC_URI="http://www.linux-stats.org/download/LiSt-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+RESTRICT=""
+SLOT="0"
+
+IUSE=""
+RDEPEND=">=dev-lang/python-2.4.0
+	>=net-misc/wget-1.10.2
+	>=sys-apps/sed-4.1.4
+	>=sys-apps/util-linux-2.12r"
+
+S=${WORKDIR}/LiSt-${PV}
+
+pkg_setup() {
+	einfo "Adding new group \"stats\"..."
+	enewgroup stats
+}
+
+src_install() {
+	declare CONFIGDIR=/etc/LiSt
+	dodir ${CONFIGDIR}
+	fowners root:stats ${CONFIGDIR}
+	fperms g+wx ${CONFIGDIR}
+	dobin src/LiSt
+	cd doc
+	dodoc README INSTALL AUTHORS
+}
+
+pkg_postinst() {
+	echo ""
+	ewarn "+---------------------------------------------------+"
+	ewarn "| You have to be in the stats group to use this     |"
+	ewarn "| software! You can add yourself to the stats group |"
+	ewarn "| by running the following command:                 |"
+	ewarn "|                                                   |"
+	ewarn "|     gpasswd -a <user> stats                       |"
+	ewarn "|                                                   |"
+	ewarn "| Then you have to re-login with your user!         |"
+	ewarn "+---------------------------------------------------+"
+	ewarn "| Start this application by typing \"LiSt\" in your   |"
+	ewarn "| console. To get some help, try \"LiSt -h\".         |"
+	ewarn "| To run this application every 24h in a cronjob,   |"
+	ewarn "| add the following to \"crontab -e\":                |"
+	ewarn "|                                                   |"
+	ewarn "| 0 12 * * * /usr/bin/LiSt -uy &>/dev/null          |"
+	ewarn "+---------------------------------------------------+"
+	ewarn "| Please read also the following README:            |"
+	ewarn "| /usr/share/doc/${PF}/README.gz              |"
+	ewarn "+---------------------------------------------------+"
+	echo ""
+}
-- 
cgit v1.2.3-65-gdbad