summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild')
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
new file mode 100644
index 000000000000..f814422a9102
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-0.5.1.ebuild,v 1.1 2009/08/25 10:34:19 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Battery status panel plugin"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.5/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=xfce-base/xfce4-panel-4.3.90.2
+ >=xfce-base/libxfce4util-4.3.90.2
+ >=xfce-base/libxfcegui4-4.3.90.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}/${PV}-freebsd.patch"
+ "${FILESDIR}/${PV}-libacpi.patch"
+ "${FILESDIR}/${PV}-2.6.24-headers.patch"
+ "${FILESDIR}/${PV}-sysfs.patch" )
+ DOCS="AUTHORS ChangeLog README"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}