summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog9
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.16
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.6.1.ebuild31
3 files changed, 45 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 92b3032dc15d..8a76ac921dea 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.26 2006/06/05 21:38:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.27 2006/06/16 07:29:23 spyderous Exp $
+
+*xf86-video-ati-6.6.1 (16 Jun 2006)
+
+ 16 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +xf86-video-ati-6.6.1.ebuild:
+ Bump. Fixes PCIE suspend/resume, lots of EXA fixes, interrupt handling, and
+ more.
05 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
xf86-video-ati-6.6.0.ebuild:
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.1 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.1
new file mode 100644
index 000000000000..e6680c230c66
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.1
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 76445561906956fee384017e22d803ae xf86-video-ati-6.6.1.tar.bz2 675870
+RMD160 3b8a872261bbd85f85ffa1132a25dbc1efb00d65 xf86-video-ati-6.6.1.tar.bz2 675870
+SHA256 2bed11d2e49e9eff5d999e4c74b35906692e002ceca68887e4a5fbccac278f53 xf86-video-ati-6.6.1.tar.bz2 675870
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.1.ebuild
new file mode 100644
index 000000000000..ea39990f18a7
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.1.ebuild,v 1.1 2006/06/16 07:29:23 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}