summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/ChangeLog6
-rw-r--r--sys-process/at/at-3.1.13-r2.ebuild6
-rw-r--r--sys-process/at/files/atd.service13
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index c3d868210159..efa863ce14a3 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/at
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.45 2013/02/27 13:06:29 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.46 2013/07/13 12:09:27 pacho Exp $
+
+ 13 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/atd.service,
+ at-3.1.13-r2.ebuild:
+ Install unit file (#471126)
27 Feb 2013; Lars Wendler <polynomial-c@gentoo.org>
-files/at-3.1.10.1-Makefile.patch, -at-3.1.10.2-r1.ebuild,
diff --git a/sys-process/at/at-3.1.13-r2.ebuild b/sys-process/at/at-3.1.13-r2.ebuild
index b8481f30c4c9..862c8ff204e1 100644
--- a/sys-process/at/at-3.1.13-r2.ebuild
+++ b/sys-process/at/at-3.1.13-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13-r2.ebuild,v 1.2 2013/02/27 13:06:29 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.13-r2.ebuild,v 1.3 2013/07/13 12:09:27 pacho Exp $
EAPI=4
-inherit autotools eutils flag-o-matic pam user
+inherit autotools eutils flag-o-matic pam user systemd
DESCRIPTION="Queues jobs for later execution"
HOMEPAGE="http://packages.qa.debian.org/a/at.html"
@@ -68,6 +68,8 @@ src_install() {
einfo "Preserving existing .SEQ file (bug #386625)."
cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
}
pkg_postinst() {
diff --git a/sys-process/at/files/atd.service b/sys-process/at/files/atd.service
new file mode 100644
index 000000000000..2910c7e4a4aa
--- /dev/null
+++ b/sys-process/at/files/atd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=at (job queue) daemon
+After=networking.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/atd
+PIDFile=/var/run/atd.pid
+StandardOutput=syslog
+StandardError=syslog
+
+[Install]
+WantedBy=multi-user.target