summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog9
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.97-r16
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.97-r1.ebuild72
3 files changed, 86 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 3a0bcd581d8b..4644fc23b629 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.65 2007/10/28 07:11:25 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.66 2007/11/03 15:08:58 alonbl Exp $
+
+*hibernate-script-1.97-r1 (03 Nov 2007)
+
+ 03 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.97-r1.ebuild:
+ Fix tuxonice filewriter issue, bug#197630, thanks Frittella Laurento for
+ reporting
28 Oct 2007; Alon Bar-Lev <alonbl@gentoo.org>
files/digest-hibernate-script-1.97, Manifest:
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.97-r1 b/sys-power/hibernate-script/files/digest-hibernate-script-1.97-r1
new file mode 100644
index 000000000000..274de2cdfc88
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.97-r1
@@ -0,0 +1,6 @@
+MD5 5b665c18375c06d26cab32f2fecfcccf hibernate-script-1.97-patches-2.tar.bz2 2565
+RMD160 81dac087993e2f4cd1b27acd5c958e76c35d75b8 hibernate-script-1.97-patches-2.tar.bz2 2565
+SHA256 e93618f4da19ea98114708cf67435fe0461bdb7cede9c1474db46b0230b4b8ec hibernate-script-1.97-patches-2.tar.bz2 2565
+MD5 c3551238a2fe8bbe7b0e20322d8e02a5 hibernate-script-1.97.tar.gz 81504
+RMD160 6346a098f0892e6cffd547b0b7d042a51f298bb2 hibernate-script-1.97.tar.gz 81504
+SHA256 8374bedc80206a6708c10d9814b92bebed3d9e4966c01c2d086e9e5b5646827c hibernate-script-1.97.tar.gz 81504
diff --git a/sys-power/hibernate-script/hibernate-script-1.97-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.97-r1.ebuild
new file mode 100644
index 000000000000..7a0301878a71
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.97-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.97-r1.ebuild,v 1.1 2007/11/03 15:08:58 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="2"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim-syntax"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )
+ !<media-gfx/splashutils-1.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}