summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog10
-rw-r--r--sys-devel/autoconf/autoconf-2.52d-r1.ebuild118
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.52d-r12
-rw-r--r--sys-devel/automake/ChangeLog10
-rw-r--r--sys-devel/automake/automake-1.5d-r2.ebuild116
-rw-r--r--sys-devel/automake/files/digest-automake-1.5d-r22
6 files changed, 256 insertions, 2 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 334adb58cd9c..30263c170254 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.2 2002/03/21 07:50:11 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.3 2002/04/07 06:35:07 azarah Exp $
+
+autoconf-1.52d-r1 (21 March 2002)
+
+7 April 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Change the names of the 2.5x binaries to foo-${PV}, since they do support
+ limited parallel versions, and foo-2.5x breaks recursion if they call
+ themselfs. Fixed doc paths.
*autoconf-2.53 (21 March 2002)
diff --git a/sys-devel/autoconf/autoconf-2.52d-r1.ebuild b/sys-devel/autoconf/autoconf-2.52d-r1.ebuild
new file mode 100644
index 000000000000..2439afe0c835
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.52d-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.52d-r1.ebuild,v 1.1 2002/04/07 06:35:07 azarah Exp $
+
+OLD_PV=2.13
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+DEPEND=">=sys-devel/m4-1.4p
+ sys-devel/perl"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${OLD_S}
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure-gentoo.diff || die
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff || die
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+ mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.52d-r1 b/sys-devel/autoconf/files/digest-autoconf-2.52d-r1
new file mode 100644
index 000000000000..fdbf6fcd2ead
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.52d-r1
@@ -0,0 +1,2 @@
+MD5 e8be7e4bb13a7ad33156ad15029814ba autoconf-2.52d.tar.bz2 698820
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 37c7260101dc..261dfff601e6 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/automake
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.3 2002/03/21 20:45:42 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.4 2002/04/07 06:35:03 azarah Exp $
+
+automake-1.5d-r2 (21 March 2002)
+
+ 7 April 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Change the names of the 1.5x binaries to foo-${PV}, since they do support
+ limited parallel versions, and foo-1.5x breaks recursion if they call
+ themselfs. Fixed doc paths.
*automake-1.6-r1 (21 March 2002)
diff --git a/sys-devel/automake/automake-1.5d-r2.ebuild b/sys-devel/automake/automake-1.5d-r2.ebuild
new file mode 100644
index 000000000000..a39cce87cda9
--- /dev/null
+++ b/sys-devel/automake/automake-1.5d-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5d-r2.ebuild,v 1.1 2002/04/07 06:35:03 azarah Exp $
+
+OLD_PV=1.4-p5
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+SRC_URI="ftp://sources.redhat.com/pub/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/automake/automake.html"
+
+DEPEND="sys-devel/perl
+ >=sys-devel/autoconf-2.52-r1"
+
+
+src_compile() {
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${S}
+
+ cp automake.texi automake.texi.orig
+ sed -e "s:setfilename automake.info:setfilename automake-1.5.info:" \
+ automake.texi.orig >automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+
+ unset WANT_AUTOCONF_2_5
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/am-wrapper.pl-1.5 am-wrapper.pl
+ dosed "s:1\.5x:${PV}:g" /usr/lib/${PN}/am-wrapper.pl
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x}-${PV} ${D}/usr/bin/${x}-${PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake-1.5.info*
+
+ docinto ${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-1.4
+ dosym ../lib/${PN}/am-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in automake aclocal
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/automake/files/digest-automake-1.5d-r2 b/sys-devel/automake/files/digest-automake-1.5d-r2
new file mode 100644
index 000000000000..feb51fd9db4a
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.5d-r2
@@ -0,0 +1,2 @@
+MD5 78b3eb4d3d593ceaa32c1d33d6abcdf6 automake-1.5d.tar.bz2 455041
+MD5 e10679bba411f8602eed004012d915e3 automake-1.4-p5.tar.gz 376992