summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/openpam/ChangeLog9
-rw-r--r--sys-auth/openpam/openpam-20071221.ebuild24
2 files changed, 16 insertions, 17 deletions
diff --git a/sys-auth/openpam/ChangeLog b/sys-auth/openpam/ChangeLog
index 2d5a9d430be6..d35e7b1366ac 100644
--- a/sys-auth/openpam/ChangeLog
+++ b/sys-auth/openpam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/openpam
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.15 2009/07/08 17:00:46 the_paya Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.16 2010/05/02 11:20:56 aballier Exp $
+
+ 02 May 2010; Alexis Ballier <aballier@gentoo.org> openpam-20071221.ebuild:
+ Various improvements to the ebuild by Toffanin [Gentoo/FreeBSD AT]
+ <toffanin.mauro@gmail.com> in bug #318121, esp. missing || die at make
+ install
08 Jul 2009; Javier Villavicencio <the_paya@gentoo.org>
openpam-20071221.ebuild:
diff --git a/sys-auth/openpam/openpam-20071221.ebuild b/sys-auth/openpam/openpam-20071221.ebuild
index abe7a979fda6..36a408a3ef8c 100644
--- a/sys-auth/openpam/openpam-20071221.ebuild
+++ b/sys-auth/openpam/openpam-20071221.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20071221.ebuild,v 1.5 2009/07/08 17:00:46 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20071221.ebuild,v 1.6 2010/05/02 11:20:56 aballier Exp $
-inherit multilib flag-o-matic autotools
+EAPI="2"
+inherit multilib autotools
DESCRIPTION="Open source PAM library."
HOMEPAGE="http://www.openpam.org/"
@@ -21,10 +22,7 @@ PDEPEND="sys-auth/pambase
PROVIDE="virtual/pam"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}/${P}-gentoo.patch"
epatch "${FILESDIR}/${PN}-20050201-nbsd.patch"
epatch "${FILESDIR}/${PN}-20050616-redef.patch"
@@ -36,18 +34,14 @@ src_unpack() {
elibtoolize
}
-src_compile() {
- econf \
+src_configure() {
+ econf ${myconf} \
--disable-dependency-tracking \
- --with-modules-dir=/$(get_libdir)/security/ \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ --with-modules-dir=/$(get_libdir)/security/
}
src_install() {
- emake -j1 DESTDIR="${D}" install
-
+ emake -j1 DESTDIR="${D}" install || die
dodoc CREDITS HISTORY RELNOTES README || die
find "${D}" -name '*.la' -delete || die