summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/ChangeLog10
-rw-r--r--sys-apps/qingy/files/digest-qingy-0.9.36
-rw-r--r--sys-apps/qingy/qingy-0.7.4.ebuild20
-rw-r--r--sys-apps/qingy/qingy-0.9.3.ebuild130
4 files changed, 155 insertions, 11 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 7b1ef965157f..fd6456815554 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.37 2006/10/27 18:09:15 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.38 2006/11/10 12:36:03 s4t4n Exp $
+
+*qingy-0.9.3 (10 Nov 2006)
+
+ 10 Nov 2006; Michele Noberasco <s4t4n@gentoo.org> qingy-0.9.3.ebuild:
+ Version bump. This version fixed compilation issues with OpenSSL.
+ Also, USE flags names are rationalized, see bug #153167.
+ qingy-0.9.2.ebuild:
+ Wiped out previous release...
27 Oct 2006; Sven Wegener <swegener@gentoo.org> qingy-0.9.2.ebuild:
Use full atoms for built_with_use.
diff --git a/sys-apps/qingy/files/digest-qingy-0.9.3 b/sys-apps/qingy/files/digest-qingy-0.9.3
new file mode 100644
index 000000000000..423452cf63a6
--- /dev/null
+++ b/sys-apps/qingy/files/digest-qingy-0.9.3
@@ -0,0 +1,6 @@
+MD5 74b32d5b07d667dc6050143e5891ca74 qingy-0.9.3.tar.bz2 611975
+RMD160 e7a47bc97c64881aa11d73fe5adbdf321e69b8ba qingy-0.9.3.tar.bz2 611975
+SHA256 c752ea7c6cae656708adacf15156b2b313b30624ddc5fb81cbb93169d928daa3 qingy-0.9.3.tar.bz2 611975
+MD5 67510c456345db3be0f146257d445cce qingy-gentoo-theme.tar.bz2 147139
+RMD160 d0b5aae66ecb1d473c1e6b1e003e45834e82e469 qingy-gentoo-theme.tar.bz2 147139
+SHA256 a5b01b1d6ed8a008d3a6f0bc59c58c47dac914a7e4cd641864493c96c70dfac7 qingy-gentoo-theme.tar.bz2 147139
diff --git a/sys-apps/qingy/qingy-0.7.4.ebuild b/sys-apps/qingy/qingy-0.7.4.ebuild
index e99b4bd37b4c..d60a452052e3 100644
--- a/sys-apps/qingy/qingy-0.7.4.ebuild
+++ b/sys-apps/qingy/qingy-0.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.7.4.ebuild,v 1.5 2006/10/13 10:39:24 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.7.4.ebuild,v 1.6 2006/11/10 12:36:03 s4t4n Exp $
DESCRIPTION="a DirectFB getty replacement"
HOMEPAGE="http://qingy.sourceforge.net/"
@@ -9,13 +9,13 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
-IUSE="crypto_openssl crypto_libgcrypt emacs gpm pam static"
+IUSE="crypt emacs gpm opensslcrypt pam static"
RDEPEND=">=dev-libs/DirectFB-0.9.18
- crypto_openssl? ( >=dev-libs/openssl-0.9.7e )
- crypto_libgcrypt? ( >=dev-libs/libgcrypt-1.2.1 )
- emacs? ( virtual/emacs )
- pam? ( >=sys-libs/pam-0.75-r11 )
+ opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
+ crypt? ( >=dev-libs/libgcrypt-1.2.1 )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
>=sys-libs/ncurses-5.4-r6
|| ( (
x11-libs/libX11
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
src_unpack()
{
- if use crypto_openssl && use crypto_libgcrypt; then
+ if use opensslcrypt && use crypt; then
echo
eerror "You can have openssl or libgcrypt as a crypto library, not both."
eerror "Please check your USE flags..."
@@ -43,8 +43,8 @@ src_compile()
{
local crypto_support="--disable-crypto"
- use crypto_openssl && crypto_support="--enable-crypto=openssl"
- use crypto_libgcrypt && crypto_support="--enable-crypto=libgcrypt"
+ use opensslcrypt && crypto_support="--enable-crypto=openssl"
+ use crypt && crypto_support="--enable-crypto=libgcrypt"
econf \
--sbindir=/sbin \
@@ -86,7 +86,7 @@ pkg_postinst()
ewarn "and http://bugs.gentoo.org/show_bug.cgi?id=60402"
ewarn "Use either a 2.6.5 or a >=2.6.8 kernel!"
- if use crypto_libgcrypt; then
+ if use crypt; then
echo
einfo "You will have to create a key pair using 'qingy-keygen'"
fi
diff --git a/sys-apps/qingy/qingy-0.9.3.ebuild b/sys-apps/qingy/qingy-0.9.3.ebuild
new file mode 100644
index 000000000000..02f894dabc52
--- /dev/null
+++ b/sys-apps/qingy/qingy-0.9.3.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.9.3.ebuild,v 1.1 2006/11/10 12:36:03 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="a DirectFB getty replacement"
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-gentoo-theme.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="crypt directfb emacs gpm logrotate opensslcrypt pam static X"
+
+RDEPEND=">=sys-libs/ncurses-5.4-r6
+ opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
+ crypt? ( >=dev-libs/libgcrypt-1.2.1 )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ X? ( || ( (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-proto/scrnsaverproto )
+ virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=sys-apps/sed-4.1.4-r1"
+
+src_unpack()
+{
+ if use crypt && use opensslcrypt; then
+ echo
+ eerror "You can have openssl or libgcrypt as a crypto library, not both."
+ eerror "Please check your USE flags..."
+ echo
+ die "USE flags check failed"
+ fi
+
+ if use directfb; then
+
+ #Issues with this version have been work-arounded :-)
+ #if has_version "=dev-libs/DirectFB-0.9.25.1"; then
+ # echo
+ # ewarn "You are running DirectFB version 0.9.25.1:"
+ # ewarn "I advise against that as this version introduces"
+ # ewarn "instability, expecially when closing DirectFB mode!"
+ # ewarn "Please consider downgrading DirectFB to version 0.9.24..."
+ # echo
+ # epause
+ #fi
+
+ if ! built_with_use -a dev-libs/DirectFB fbcon jpeg png truetype; then
+ echo
+ eerror "qingy expects DirectFB to provide certain capabilities."
+ eerror "It depends on the theme you use, but at least the following USE flags"
+ eerror "should be enabled in DirectFB: fbcon jpeg png truetype."
+ eerror "You must rebuild DirectFB those USE flags enabled!"
+ echo
+ die "USE flags check failed"
+ fi
+
+ fi
+
+ unpack ${A}
+}
+
+src_compile()
+{
+ local crypto_support="--disable-crypto"
+
+ use opensslcrypt && crypto_support="--enable-crypto=openssl"
+ use crypt && crypto_support="--enable-crypto=libgcrypt"
+
+ econf \
+ --sbindir=/sbin \
+ --disable-optimizations \
+ `use_enable emacs` \
+ `use_enable pam` \
+ `use_enable static static-build` \
+ `use_enable gpm gpm-lock` \
+ `use_enable X x-support` \
+ `use_enable directfb DirectFB-support` \
+ ${crypto_support} \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install()
+{
+ # Copy documentation manually as make install only installs info files
+ # INSTALL is left because it contains also configuration informations
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+
+ # Install the program
+ make DESTDIR=${D} install || die "Installation failed"
+
+ # Set the settings file umask to 600, in case somebody
+ # wants to make use of the autologin feature
+ /bin/chmod 600 ${D}/etc/qingy/settings
+
+ # Install Gentoo theme
+ dodir /usr/share/${PN}/themes/gentoo
+ cp ${WORKDIR}/gentoo/* ${D}/usr/share/${PN}/themes/gentoo \
+ || die "Gentoo theme installation failed"
+
+ # Alter config file so that it uses our theme
+ sed -i 's/theme = "default"/theme = "gentoo"/' ${D}/etc/${PN}/settings
+
+ # Install log rotation policy if user wants it
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins ${FILESDIR}/${PN}-logrotate ${PN} || die "Log rotation policy installation failed"
+ fi
+}
+
+pkg_postinst()
+{
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check the documentation at ${HOMEPAGE}"
+ einfo "for instructions on how to do that."
+
+ if use crypt; then
+ echo
+ einfo "You will have to create a key pair using 'qingy-keygen'"
+ fi
+}