summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/mpb/ChangeLog12
-rw-r--r--sci-physics/mpb/mpb-1.4.2-r2.ebuild9
2 files changed, 14 insertions, 7 deletions
diff --git a/sci-physics/mpb/ChangeLog b/sci-physics/mpb/ChangeLog
index 11765c22bd51..d9ccf3c357bd 100644
--- a/sci-physics/mpb/ChangeLog
+++ b/sci-physics/mpb/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sci-physics/mpb
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.10 2008/11/25 18:45:52 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.11 2009/08/25 01:25:28 markusle Exp $
+
+ 25 Aug 2009; Markus Dittrich <markusle@gentoo.org> mpb-1.4.2-r2.ebuild:
+ Enable hdf5-1.6 legacy API when building against hdf5-1.8
+ (fixes #282183)
*mpb-1.4.2-r2 (25 Nov 2008)
- 25 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ 25 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+files/mpb-1.4.2-autotools.patch, +files/mpb-1.4.2-headers.patch,
metadata.xml, -mpb-1.4.2.ebuild, +mpb-1.4.2-r2.ebuild:
Added hdf5, doc and examples flags. Many autotools and QA fixes: quotes,
@@ -19,7 +23,7 @@
21 Aug 2007; <pbienst@gentoo.org> mpb-1.4.2.ebuild:
Added ~amd64.
- 10 Jan 2007; Piotr Jaroszyński <peper@gentoo.org> Manifest:
+ 10 Jan 2007; Piotr Jaroszyński <peper@gentoo.org> Manifest:
Fix Manifest.
10 Jan 2007; <marijn@gentoo.org> mpb-1.4.2.ebuild:
diff --git a/sci-physics/mpb/mpb-1.4.2-r2.ebuild b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
index 31473d4275b3..2a49af273ebd 100644
--- a/sci-physics/mpb/mpb-1.4.2-r2.ebuild
+++ b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.1 2008/11/25 18:45:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.2 2009/08/25 01:25:28 markusle Exp $
EAPI=2
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
DESCRIPTION="Photonic band structure program"
SRC_URI="http://ab-initio.mit.edu/mpb/${P}.tar.gz"
@@ -45,6 +45,9 @@ src_prepare() {
}
src_configure() {
+ # enable legacy API for hdf-1.8
+ use hdf5 && append-cflags -DH5_USE_16_API
+
local myconf="$(use_with hdf5)"
export BLAS_LIBS="$(pkg-config --libs blas)"
export LAPACK_LIBS="$(pkg-config --libs lapack)"