summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/lostirc/lostirc-0.3.0.ebuild')
-rw-r--r--net-irc/lostirc/lostirc-0.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-irc/lostirc/lostirc-0.3.0.ebuild b/net-irc/lostirc/lostirc-0.3.0.ebuild
new file mode 100644
index 000000000000..d04f45803063
--- /dev/null
+++ b/net-irc/lostirc/lostirc-0.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/lostirc/lostirc-0.3.0.ebuild,v 1.1 2003/12/04 03:30:49 zul Exp $
+
+inherit base
+
+IUSE="kde gnome"
+DESCRIPTION="A simple but functional graphical IRC client"
+HOMEPAGE="http://lostirc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+S=${WORKDIR}/${P}
+DEPEND=">=sys-apps/sed-4*
+ >=dev-cpp/gtkmm-2.0
+ >=dev-libs/libsigc++-1.2"
+
+src_compile() {
+ # patch po/Makefile.in.in
+ sed -i -r 's:(^mkinstalldirs = ).*:\1$(MKINSTALLDIRS):' po/Makefile.in.in || die
+ local myconf=""
+ myconf="${myconf} `use_with gnome`"
+ myconf="${myconf} `use_with kde`"
+ econf ${myconf} || die
+ base_src_compile make
+}
+
+src_install() {
+ base_src_install
+ dodoc AUTHORS ChangeLog COPYING INSTALL README TODO NEWS
+}