summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zniper')
-rw-r--r--net-analyzer/zniper/ChangeLog8
-rw-r--r--net-analyzer/zniper/zniper-1.0-r1.ebuild28
2 files changed, 22 insertions, 14 deletions
diff --git a/net-analyzer/zniper/ChangeLog b/net-analyzer/zniper/ChangeLog
index 6604d4ffd3a3..1e5a83097780 100644
--- a/net-analyzer/zniper/ChangeLog
+++ b/net-analyzer/zniper/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/zniper
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/ChangeLog,v 1.6 2012/12/26 18:59:46 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/ChangeLog,v 1.7 2014/07/18 12:23:49 jer Exp $
+
+ 18 Jul 2014; Jeroen Roovers <jer@gentoo.org> zniper-1.0-r1.ebuild:
+ EAPI bump. Do not install README. Fix building against
+ sys-libs/ncurses[tinfo].
26 Dec 2012; Jeff Horelick <jdhore@gentoo.org> zniper-1.0-r1.ebuild:
marked x86 per bug 447734
diff --git a/net-analyzer/zniper/zniper-1.0-r1.ebuild b/net-analyzer/zniper/zniper-1.0-r1.ebuild
index 24f52ac60e1a..79d19e7459eb 100644
--- a/net-analyzer/zniper/zniper-1.0-r1.ebuild
+++ b/net-analyzer/zniper/zniper-1.0-r1.ebuild
@@ -1,31 +1,36 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/zniper-1.0-r1.ebuild,v 1.4 2012/12/26 18:59:46 jdhore Exp $
-
-EAPI=4
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zniper/zniper-1.0-r1.ebuild,v 1.5 2014/07/18 12:23:49 jer Exp $
+EAPI=5
inherit toolchain-funcs
DESCRIPTION="Displays and kill active TCP connections seen by the selected interface."
HOMEPAGE="http://www.signedness.org/tools/"
-SRC_URI="http://www.signedness.org/tools/zniper.tgz"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND="net-libs/libpcap
- sys-libs/ncurses"
-RDEPEND="${DEPEND}"
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
S=${WORKDIR}/"zniper"
src_prepare() {
- sed -i Makefile \
+ sed -i \
-e 's| -o | $(LDFLAGS)&|g' \
-e 's|@make|@$(MAKE)|g' \
- || die "sed Makefile"
+ -e 's|-lncurses|$(shell $(PKG_CONFIG) --libs ncurses)|g' \
+ Makefile || die
+ tc-export PKG_CONFIG
}
src_compile() {
@@ -37,6 +42,5 @@ src_compile() {
src_install() {
dobin zniper
- dodoc README
doman zniper.1
}