summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/abcde/abcde-1.9.7.ebuild33
-rw-r--r--media-sound/abcde/files/abcde-1.9.7-gentoo.diff.gzbin0 -> 602 bytes
-rw-r--r--media-sound/abcde/files/digest-abcde-1.9.71
-rw-r--r--media-sound/cd-discid/cd-discid-0.4.ebuild26
-rw-r--r--media-sound/cd-discid/files/digest-cd-discid-0.41
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.9.7.ebuild24
-rw-r--r--media-sound/cdparanoia/files/digest-cdparanoia-3.9.71
-rw-r--r--media-sound/id3/files/digest-id3-0.121
-rw-r--r--media-sound/id3/id3-0.12.ebuild23
9 files changed, 110 insertions, 0 deletions
diff --git a/media-sound/abcde/abcde-1.9.7.ebuild b/media-sound/abcde/abcde-1.9.7.ebuild
new file mode 100644
index 000000000000..58caa41b17cc
--- /dev/null
+++ b/media-sound/abcde/abcde-1.9.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/abcde-1.9.7.ebuild,v 1.1 2001/02/05 02:23:36 achim Exp $
+
+A=abcde_1.9.7.orig.tar.gz
+A0=abcde-1.9.7-gentoo.diff.gz
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a better cd encoder"
+SRC_URI="http://lly.org/~rcw/abcde/development/${A}"
+HOMEPAGE="http://lly.org/~rcw/abcde/page/"
+RDEPEND=">=media-sound/id3-0.12
+ >=media-sound/cd-discid-0.12
+ >=media-sound/cdparanoia-3.9.7"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ gzip -dc ${FILESDIR}/${A0} | patch -p1
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install () {
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc COPYING README TODO changelog
+}
+
diff --git a/media-sound/abcde/files/abcde-1.9.7-gentoo.diff.gz b/media-sound/abcde/files/abcde-1.9.7-gentoo.diff.gz
new file mode 100644
index 000000000000..bf2890a87000
--- /dev/null
+++ b/media-sound/abcde/files/abcde-1.9.7-gentoo.diff.gz
Binary files differ
diff --git a/media-sound/abcde/files/digest-abcde-1.9.7 b/media-sound/abcde/files/digest-abcde-1.9.7
new file mode 100644
index 000000000000..d7cc5fb791a1
--- /dev/null
+++ b/media-sound/abcde/files/digest-abcde-1.9.7
@@ -0,0 +1 @@
+MD5 88c7a822771b11e733103710719c2ce3 abcde_1.9.7.orig.tar.gz
diff --git a/media-sound/cd-discid/cd-discid-0.4.ebuild b/media-sound/cd-discid/cd-discid-0.4.ebuild
new file mode 100644
index 000000000000..988cd9b3f3b9
--- /dev/null
+++ b/media-sound/cd-discid/cd-discid-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cd-discid/cd-discid-0.4.ebuild,v 1.1 2001/02/05 02:23:36 achim Exp $
+
+A=cd-discid_0.4.orig.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="returns the disc id for the cd in the cd-rom drive"
+SRC_URI="http://lly.org/~rcw/cd-discid/${A}"
+HOMEPAGE="http://lly.org/~rcw/abcde/page/"
+
+
+src_compile() {
+
+ echo gcc ${CFLAGS} -o cd-discid cd-discid.c
+ gcc ${CFLAGS} -o cd-discid cd-discid.c
+}
+
+src_install () {
+
+ into /usr
+ dobin cd-discid
+ doman cd-discid.1
+
+ dodoc COPYING README changelog
+}
diff --git a/media-sound/cd-discid/files/digest-cd-discid-0.4 b/media-sound/cd-discid/files/digest-cd-discid-0.4
new file mode 100644
index 000000000000..3120c14d5d5c
--- /dev/null
+++ b/media-sound/cd-discid/files/digest-cd-discid-0.4
@@ -0,0 +1 @@
+MD5 a8d30701f61de0b965b074a7984ab7fd cd-discid_0.4.orig.tar.gz
diff --git a/media-sound/cdparanoia/cdparanoia-3.9.7.ebuild b/media-sound/cdparanoia/cdparanoia-3.9.7.ebuild
new file mode 100644
index 000000000000..5a19dc446b78
--- /dev/null
+++ b/media-sound/cdparanoia/cdparanoia-3.9.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/cdparanoia-3.9.7.ebuild,v 1.1 2001/02/05 02:23:36 achim Exp $
+
+A=cdparanoia-III-alpha9.7.src.tgz
+S=${WORKDIR}/cdparanoia-III-alpha9.7
+DESCRIPTION="an advanced CDDA reader with error correction"
+SRC_URI="http://www.xiph.org/paranoia/download/cdparanoia-III-alpha9.7.src.tgz"
+HOMEPAGE="http://www.xiph.org/paranoia/index.html"
+
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install () {
+ cd ${S}
+ dodir /usr/bin /usr/lib /usr/man/man1 /usr/include
+ try make prefix=${D}/usr install
+ dodoc FAQ.txt GPL README
+}
diff --git a/media-sound/cdparanoia/files/digest-cdparanoia-3.9.7 b/media-sound/cdparanoia/files/digest-cdparanoia-3.9.7
new file mode 100644
index 000000000000..9a13eb79f1e7
--- /dev/null
+++ b/media-sound/cdparanoia/files/digest-cdparanoia-3.9.7
@@ -0,0 +1 @@
+MD5 0820b2b52b721745f926c913c0a2653f cdparanoia-III-alpha9.7.src.tgz
diff --git a/media-sound/id3/files/digest-id3-0.12 b/media-sound/id3/files/digest-id3-0.12
new file mode 100644
index 000000000000..ab001464230e
--- /dev/null
+++ b/media-sound/id3/files/digest-id3-0.12
@@ -0,0 +1 @@
+MD5 5791f634b928f39ec9eaa59efb3f9315 id3_0.12.orig.tar.gz
diff --git a/media-sound/id3/id3-0.12.ebuild b/media-sound/id3/id3-0.12.ebuild
new file mode 100644
index 000000000000..798567796b84
--- /dev/null
+++ b/media-sound/id3/id3-0.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3/id3-0.12.ebuild,v 1.1 2001/02/05 02:23:36 achim Exp $
+
+A=id3_0.12.orig.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="changes the id3 tag in an mp3 file"
+SRC_URI="http://lly.org/~rcw/id3/${A}"
+HOMEPAGE="http://lly.org/~rcw/abcde/page/"
+
+
+src_compile() {
+
+ try make CFLAGS=\"${CFLAGS}\"
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc COPYING README
+
+}