summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ssrc/ssrc-1.29.ebuild')
-rw-r--r--media-sound/ssrc/ssrc-1.29.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/media-sound/ssrc/ssrc-1.29.ebuild b/media-sound/ssrc/ssrc-1.29.ebuild
index f723d1183579..90640e249827 100644
--- a/media-sound/ssrc/ssrc-1.29.ebuild
+++ b/media-sound/ssrc/ssrc-1.29.ebuild
@@ -1,24 +1,29 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ssrc/ssrc-1.29.ebuild,v 1.1 2004/02/14 06:03:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ssrc/ssrc-1.29.ebuild,v 1.1.1.1 2005/11/30 09:38:22 chriswhite Exp $
+
+inherit flag-o-matic
S=${WORKDIR}
DESCRIPTION="A fast and high quality sampling rate converter"
HOMEPAGE="http://shibatch.sourceforge.net"
-SRC_URI="http://shibatch.sf.net/download/ssrc-1.29.zip"
+SRC_URI="http://shibatch.sf.net/download/${P}.zip"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+#-amd64: 1.29: segfault on 44100 -> 11025 kde's pop.wav
+#-sparc: same test as amd64... "Error: Only PCM is supported."
+
+KEYWORDS="x86 -amd64 -sparc"
IUSE=""
-DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
+DEPEND="app-arch/unzip"
src_compile() {
append-flags -lm
# Local CFLAGS should overwrite the ones in the Makefile
- emake -e || die
+ emake -e || die
}
src_install() {