summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/dcd/dcd-0.90.ebuild')
-rw-r--r--media-sound/dcd/dcd-0.90.ebuild39
1 files changed, 23 insertions, 16 deletions
diff --git a/media-sound/dcd/dcd-0.90.ebuild b/media-sound/dcd/dcd-0.90.ebuild
index e55ee311a1aa..ad412333bb67 100644
--- a/media-sound/dcd/dcd-0.90.ebuild
+++ b/media-sound/dcd/dcd-0.90.ebuild
@@ -1,34 +1,41 @@
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Ryan Tolboom <ryan@intphsys.com>
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dcd/dcd-0.90.ebuild,v 1.1.1.1 2005/11/30 09:38:12 chriswhite Exp $
-S=${WORKDIR}/dcd-0.90
-SRC_URI="http://www.technopagan.org/dcd/dcd-0.90.tar.bz2"
+IUSE=""
+S=${WORKDIR}/dcd-0.90
+DESCRIPTION="A simple command-line based CD Player"
HOMEPAGE="http://www.technopagan.org/dcd"
+SRC_URI="http://www.technopagan.org/dcd/dcd-0.90.tar.bz2"
-DESCRIPTION="A simple command-line based CD Player"
+DEPEND="virtual/libc"
-DEPEND=">=sys-libs/glibc-2.1.3"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
src_unpack() {
- unpack ${A}
- cd ${S}
- cat Makefile | sed "s:PREFIX = .*$:PREFIX = \"${D}/usr\":" |\
- sed "s:# CDROM = /dev/cdroms/cdrom0:CDROM = \"/dev/cdroms/cdrom0\":"\
- > Makefile
-
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:PREFIX = .*$:PREFIX = \"${D}/usr\":" \
+ -e "s:/man/:/share/man/:" \
+ -e "s:# CDROM = /dev/cdroms/cdrom0:CDROM = \"/dev/cdroms/cdrom0\":"\
+ Makefile.orig > Makefile
+
}
-
+
src_compile() {
- try make
+ make EXTRA_CFLAGS="$CFLAGS" || die
}
src_install() {
- try make PREFIX=${D}/usr install
- dodoc README BUGS
+ make PREFIX=${D}/usr install || die
+ dodoc README BUGS ChangeLog
}