summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cdcd/cdcd-0.6.4.ebuild')
-rw-r--r--media-sound/cdcd/cdcd-0.6.4.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/media-sound/cdcd/cdcd-0.6.4.ebuild b/media-sound/cdcd/cdcd-0.6.4.ebuild
index 42db85046c32..bb80ae172bde 100644
--- a/media-sound/cdcd/cdcd-0.6.4.ebuild
+++ b/media-sound/cdcd/cdcd-0.6.4.ebuild
@@ -1,24 +1,32 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cdcd/cdcd-0.6.4.ebuild,v 1.1 2002/07/19 13:13:39 seemant Exp $
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdcd/cdcd-0.6.4.ebuild,v 1.1.1.1 2005/11/30 09:38:32 chriswhite Exp $
+
+IUSE=""
+
+inherit eutils gnuconfig
-S=${WORKDIR}/${P}
DESCRIPTION="a simple yet powerful command line cd player"
SRC_URI="mirror://sourceforge/libcdaudio/${P}.tar.gz"
HOMEPAGE="http://cdcd.undergrid.net/"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-libs/ncurses-5.0
>=sys-libs/readline-4.0
>=media-libs/libcdaudio-0.99.4"
-src_compile() {
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc ~amd64 ppc64"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${FILESDIR}/cdcd-0.6.4-gentoo.patch
- econf || die
- make || die
+ cd ${S}
+ gnuconfig_update
}
src_install () {
- cd ${S}
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README
}