summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/apollo/apollo-1.4.1.ebuild')
-rw-r--r--media-sound/apollo/apollo-1.4.1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/media-sound/apollo/apollo-1.4.1.ebuild b/media-sound/apollo/apollo-1.4.1.ebuild
index 244cb169319f..c4bf43e899cd 100644
--- a/media-sound/apollo/apollo-1.4.1.ebuild
+++ b/media-sound/apollo/apollo-1.4.1.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/apollo/apollo-1.4.1.ebuild,v 1.1 2002/10/04 20:25:59 hannes Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apollo/apollo-1.4.1.ebuild,v 1.1.1.1 2005/11/30 09:38:11 chriswhite Exp $
-#inherit kde-base
-#use kde && inherit kde-base
-#need-kde 3
+IUSE="kde qt"
S=${WORKDIR}/${P}-1
DESCRIPTION="A Qt-based front-end to mpg123"
@@ -15,11 +13,11 @@ SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86"
-DEPEND="media-sound/mpg123
+DEPEND="virtual/mpg123
media-libs/id3lib
- media-sound/mad
- qt? ( x11-libs/qt )
- kde? ( kde-base/kdelibs )"
+ media-sound/madplay
+ qt? ( =x11-libs/qt-3* )
+ kde? ( =kde-base/kdelibs-3* )"
# dev-libs/STLport
src_unpack() {
@@ -34,11 +32,13 @@ src_unpack() {
src_compile() {
local myconf
- myconf="--without-kde"
+ myconf="--without-kde --without-stl"
# use kde && kdeconf="--with-kde=$KDEDIR" || kdeconf="--without-kde"
- myconf="$myconf $kdeconf"
+#kde support currently does not work
+# myconf="$myconf $kdeconf"
use qt && myconf="$myconf --with-qt-dir=$QTDIR --with-qmake" || myconf="$myconf --with-tmake"
# use stl && myconf="$myconf --with-stl" || myconf="$myconf --without-stl"
+#stl support is broken
# use buffer && myconf="$myconf --enable-buffer" || myconf="$myconf --disable-buffer"
# use mad && myconf="$myconf --with-mad=/usr/lib"
myconf="$myconf --with-mad=/usr/lib"