summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jhead/jhead-2.4.ebuild')
-rw-r--r--media-gfx/jhead/jhead-2.4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-gfx/jhead/jhead-2.4.ebuild b/media-gfx/jhead/jhead-2.4.ebuild
index 9dca654feb85..559fa4029cf1 100644
--- a/media-gfx/jhead/jhead-2.4.ebuild
+++ b/media-gfx/jhead/jhead-2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.4.ebuild,v 1.1 2005/09/10 19:04:25 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.4.ebuild,v 1.1.1.1 2005/11/30 09:37:41 chriswhite Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
HOMEPAGE="http://www.sentex.net/~mwandel/jhead/"
@@ -18,11 +18,12 @@ RDEPEND="virtual/libc
src_unpack() {
unpack ${A}; cd ${S}
- epatch ${FILESDIR}/${P}-gcc4.diff
+ epatch "${FILESDIR}"/${P}-gcc4.diff
sed -i "s:-O3 -Wall:${CFLAGS}:" makefile || die
}
src_compile() {
+ export CC="$(tc-getCC)"
emake || die
}