summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fbv/fbv-0.99.ebuild')
-rw-r--r--media-gfx/fbv/fbv-0.99.ebuild33
1 files changed, 15 insertions, 18 deletions
diff --git a/media-gfx/fbv/fbv-0.99.ebuild b/media-gfx/fbv/fbv-0.99.ebuild
index dba3d242b4bd..fdcfd0152bb9 100644
--- a/media-gfx/fbv/fbv-0.99.ebuild
+++ b/media-gfx/fbv/fbv-0.99.ebuild
@@ -1,42 +1,39 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.1 2003/08/25 13:43:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbv/fbv-0.99.ebuild,v 1.1.1.1 2005/11/30 09:37:26 chriswhite Exp $
-IUSE="png gif jpeg"
+inherit toolchain-funcs
-DESCRIPTION="fbv is a simple program to view pictures on a linux framebuffer device"
+DESCRIPTION="simple program to view pictures on a linux framebuffer device"
HOMEPAGE="http://s-tech.elsat.net.pl/fbv/"
-SRC_URI="http://s-tech.elsat.net.pl/fbv//${P}.tar.gz"
+SRC_URI="http://s-tech.elsat.net.pl/fbv/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+SLOT="0"
+KEYWORDS="x86 ppc64"
+IUSE="png gif jpeg"
-DEPEND="gif? ( media-libs/libungif )
+DEPEND="gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )"
src_compile() {
-
local myconf
-
+ sed -e 's/-lungif/-lgif/g' -i Makefile -i configure
use png || myconf="${myconf} --without-libpng"
use gif || myconf="${myconf} --without-libungif"
use jpeg || myconf="${myconf} --without-libjpeg"
-
./configure \
--prefix=/usr \
- --bindir=/usr/bin \
- --infodir=/usr/share/info \
--mandir=/usr/share/man \
- ${myconf} || die
- emake CC="${CC} ${CFLAGS}" || die
+ --infodir=/usr/share/info \
+ ${myconf} || die "econf failed"
+
+ emake CC="$(tc-getCC) ${CFLAGS}" || die
}
src_install() {
-
- dobin fbv
+ dobin fbv || die
doman fbv.1
-
dodoc ChangeLog README TODO VERSION
}