summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/tork')
-rw-r--r--kde-misc/tork/ChangeLog7
-rw-r--r--kde-misc/tork/files/digest-tork-0.103
-rw-r--r--kde-misc/tork/tork-0.10.ebuild33
3 files changed, 42 insertions, 1 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index 3ec9d2b0207d..9283fa40c826 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tork
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.9 2006/10/20 23:34:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.10 2006/10/24 19:57:54 flameeyes Exp $
+
+*tork-0.10 (24 Oct 2006)
+
+ 24 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +tork-0.10.ebuild:
+ Version bump.
20 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
-files/tork-0.09-gcc41.patch, tork-0.09.ebuild:
diff --git a/kde-misc/tork/files/digest-tork-0.10 b/kde-misc/tork/files/digest-tork-0.10
new file mode 100644
index 000000000000..4b67491ca71b
--- /dev/null
+++ b/kde-misc/tork/files/digest-tork-0.10
@@ -0,0 +1,3 @@
+MD5 50afcc32ce0c82bd08afb57f6db003d1 tork-0.10.tar.bz2 1900356
+RMD160 61b4c24239d34b3a9a5519b390ae8d4f767aceaa tork-0.10.tar.bz2 1900356
+SHA256 4721123bbad9ce3a086b9f3d8ed39219cf363dbfcb8cea90c4b170f46bccff58 tork-0.10.tar.bz2 1900356
diff --git a/kde-misc/tork/tork-0.10.ebuild b/kde-misc/tork/tork-0.10.ebuild
new file mode 100644
index 000000000000..9b6d379f896c
--- /dev/null
+++ b/kde-misc/tork/tork-0.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.10.ebuild,v 1.1 2006/10/24 19:57:54 flameeyes Exp $
+
+inherit kde
+
+DESCRIPTION="A Tor controller for the KDE desktop"
+HOMEPAGE="http://tork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/geoip-1.4.0"
+
+RDEPEND="net-misc/tor
+ >=net-proxy/privoxy-3.0.3-r5
+ ${DEPEND}"
+
+need-kde 3.5
+
+src_compile() {
+ local myconf="--with-external-geoip"
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ rm -rf "${D}/usr/share/applnk"
+}