summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/openglad/openglad-0.98.ebuild')
-rw-r--r--games-rpg/openglad/openglad-0.98.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/games-rpg/openglad/openglad-0.98.ebuild b/games-rpg/openglad/openglad-0.98.ebuild
index 7b799729c811..ffbb4dcdc788 100644
--- a/games-rpg/openglad/openglad-0.98.ebuild
+++ b/games-rpg/openglad/openglad-0.98.ebuild
@@ -1,31 +1,41 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/openglad/openglad-0.98.ebuild,v 1.1 2003/09/10 06:26:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/openglad/openglad-0.98.ebuild,v 1.2 2003/12/31 19:03:05 vapier Exp $
-inherit games
+inherit games eutils
DESCRIPTION="An SDL clone of Gladiator, a classic RPG game"
-HOMEPAGE="http://snowstorm.sf.net/"
+HOMEPAGE="http://snowstorm.sourceforge.net/"
SRC_URI="mirror://sourceforge/snowstorm/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
-IUSE=""
+KEYWORDS="x86"
DEPEND=">=media-libs/sdl-mixer-1.2.5
>=media-libs/sdl-image-1.2.2
>=media-libs/libsdl-1.2.0"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gladpack.c.patch
+}
+
src_compile() {
- egamesconf --datadir=/usr/share/games/openglad \
- --prefix=/usr --bindir=/usr/games/bin || die
+ egamesconf \
+ --prefix=/usr \
+ --bindir=${GAMES_BINDIR} \
+ --datadir=${GAMES_DATADIR}/${PN} \
+ || die
emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
- rm ${D}${GAMES_DATADIR_BASE}/doc/${PN}/COPYING
- gzip -9 ${D}${GAMES_DATADIR_BASE}/doc/${PN}/*
+ make install \
+ DESTDIR=${D} \
+ docdir=${D}/usr/share/doc/${PF} \
+ || die "make install failed"
+ prepalldocs
prepgamesdirs
}