summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/toppler/toppler-1.1.3.ebuild')
-rw-r--r--games-puzzle/toppler/toppler-1.1.3.ebuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.3.ebuild b/games-puzzle/toppler/toppler-1.1.3.ebuild
index 6ea32b45701b..2f2710d305e9 100644
--- a/games-puzzle/toppler/toppler-1.1.3.ebuild
+++ b/games-puzzle/toppler/toppler-1.1.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.3.ebuild,v 1.4 2008/06/25 19:09:08 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.3.ebuild,v 1.5 2009/02/06 22:31:48 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="Reimplementation of Nebulous using SDL"
@@ -14,31 +15,16 @@ KEYWORDS="amd64 ppc x86"
IUSE="nls"
RDEPEND="media-libs/libsdl
- media-libs/sdl-mixer
+ media-libs/sdl-mixer[vorbis]
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
S=${WORKDIR}/${P/a/}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e 's/ install-dist_pkgdocDATA//' \
- -e '/^applicationsdir/ s:$(datadir):/usr/share:' \
- -e '/^pixmapsdir/ s:$(datadir):/usr/share:' \
- Makefile.in \
- || die "sed failed"
- sed -i \
- -e '/^localedir/ s:$(datadir):/usr/share:' \
- po/Makefile.in.in \
- || die "sed failed"
-}
-
-src_compile() {
- egamesconf $(use_enable nls) || die
- emake || die "emake failed"
+src_configure() {
+ egamesconf $(use_enable nls)
}
src_install() {