summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/americas-army')
-rw-r--r--games-fps/americas-army/ChangeLog39
-rw-r--r--games-fps/americas-army/Manifest7
-rw-r--r--games-fps/americas-army/americas-army-170.ebuild64
-rw-r--r--games-fps/americas-army/americas-army-190.ebuild63
-rw-r--r--games-fps/americas-army/files/armyops4
-rw-r--r--games-fps/americas-army/files/digest-americas-army-1701
-rw-r--r--games-fps/americas-army/files/digest-americas-army-1901
-rw-r--r--games-fps/americas-army/metadata.xml12
8 files changed, 191 insertions, 0 deletions
diff --git a/games-fps/americas-army/ChangeLog b/games-fps/americas-army/ChangeLog
new file mode 100644
index 000000000000..e0bee5bd4279
--- /dev/null
+++ b/games-fps/americas-army/ChangeLog
@@ -0,0 +1,39 @@
+# ChangeLog for app-games/americas-army
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/ChangeLog,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+ 27 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-170.ebuild, americas-army-190.ebuild:
+ Added esound dependency. Closes bug #27320.
+
+*americas-army-190 (25 Aug 2003)
+
+ 25 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-190.ebuild:
+ Updated to newest version and setting it as stable. I will be removing the
+ older version in one week, since it will no longer be valid. I am also working
+ on a version of this with dedicated server support, since the dedicated server
+ is now shipped with the game.
+
+ 06 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-170.ebuild:
+ I removed an extra line when cleaning up the ebuild which caused problems. The
+ line has been added back to the ebuild.
+
+ 05 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-170.ebuild:
+ Fixed to use unpack_makeself
+
+ 04 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-170.ebuild:
+ Finally added license file
+
+ 16 Jul 2003; Chris Gianelloni <wolf31o2@gentoo.org>
+ americas-army-170.ebuild:
+ Changed executable script to armyops, to match executable name. Added item to
+ create .desktop entries for Gnome/KDE.
+
+*americas-army-170 (21 Jun 2003)
+
+ 21 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Chris Gianelloni <wolf31o2@hotmail.com> #21947.
diff --git a/games-fps/americas-army/Manifest b/games-fps/americas-army/Manifest
new file mode 100644
index 000000000000..38a095c2b5f1
--- /dev/null
+++ b/games-fps/americas-army/Manifest
@@ -0,0 +1,7 @@
+MD5 fa84e67c901447cdea30dc3caa026569 ChangeLog 1584
+MD5 1e47e90b5ced130a0e602349c6cf31c5 americas-army-170.ebuild 1671
+MD5 f1a9a44e85e58296a3710c291666ab78 metadata.xml 672
+MD5 34511cfe0dbf8a9dcd538347dd6dea4e americas-army-190.ebuild 1580
+MD5 33d496501eb5585920dd91e263e8868c files/digest-americas-army-170 70
+MD5 ecd9684b31f56c72a9554791fee4f77c files/armyops 40
+MD5 68aec154834eb5edeaf1072e78ba4e52 files/digest-americas-army-190 68
diff --git a/games-fps/americas-army/americas-army-170.ebuild b/games-fps/americas-army/americas-army-170.ebuild
new file mode 100644
index 000000000000..b006549c73bd
--- /dev/null
+++ b/games-fps/americas-army/americas-army-170.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-170.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games
+
+DESCRIPTION="America's Army: Operations - military simulations by the U.S. Army to provide civilians with insights on soldiering"
+HOMEPAGE="http://www.americasarmy.com/"
+SRC_URI="ftp://ftp.stenstad.net/mirrors/icculus.org/armyops-lnx-${PV}.sh.bin
+ http://guinness.devrandom.net/%7Eprimus/armyops-lnx-${PV}.sh.bin
+ http://www.3ddownloads.com/linuxgames/americas_army/armyops-lnx-${PV}.sh.bin"
+
+LICENSE="Army-EULA"
+SLOT="0"
+KEYWORDS="x86"
+RESTRICT="nostrip"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="media-sound/esound
+ virtual/x11
+ virtual/opengl"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ ewarn "The installed game takes about 850MB of space!"
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself || die
+ tar -zxf setupstuff.tar.gz || die
+}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+
+ tar -jxf armyops${PV}System.tar.bz2 -C ${D}/${dir}/ || die
+ tar -jxf armyops${PV}data.tar.bz2 -C ${D}/${dir}/ || die
+
+ dodoc README.linux
+ insinto ${dir} ; doins ArmyOps.xpm
+ insinto /usr/share/pixmaps ; doins ArmyOps.xpm
+ exeinto ${dir} ; doexe bin/armyops
+
+ sed -e "s:GENTOO_DIR:${dir}:" ${FILESDIR}/armyops > armyops
+ dogamesbin armyops
+ dosym ${dir}/armyops ${GAMES_BINDIR}/armyops
+
+ prepgamesdirs
+ make_desktop_entry armyops "AA: Operations" ArmyOps.xpm
+
+}
+
+pkg_postinst() {
+ einfo "To play the game run:"
+ einfo " armyops"
+
+ games_pkg_postinst
+}
diff --git a/games-fps/americas-army/americas-army-190.ebuild b/games-fps/americas-army/americas-army-190.ebuild
new file mode 100644
index 000000000000..62479f803974
--- /dev/null
+++ b/games-fps/americas-army/americas-army-190.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/americas-army/americas-army-190.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games
+
+DESCRIPTION="America's Army: Operations - military simulations by the U.S. Army to provide civilians with insights on soldiering"
+HOMEPAGE="http://www.americasarmy.com/"
+SRC_URI="ftp://armyops:ftp@guinness.devrandom.net:7000/armyops${PV}-linux.bin
+ ftp://armyops:ftp@2dollar.unixwhore.com:69/armyops${PV}-linux.bin
+ http://www.biot.com/misc/armyops${PV}-linux.bin"
+
+LICENSE="Army-EULA"
+SLOT="0"
+KEYWORDS="x86"
+RESTRICT="nostrip"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="media-sound/esound
+ virtual/x11
+ virtual/opengl"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ ewarn "The installed game takes about 1.3GB of space!"
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself || die
+ tar -zxf setupstuff.tar.gz || die
+}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+
+ tar -jxf armyops${PV}.tar.bz2 -C ${D}/${dir}/ || die
+
+ dodoc README.linux
+ insinto ${dir} ; doins ArmyOps.xpm
+ insinto /usr/share/pixmaps ; doins ArmyOps.xpm
+ exeinto ${dir} ; doexe bin/armyops
+
+ sed -e "s:GENTOO_DIR:${dir}:" ${FILESDIR}/armyops > armyops
+ dogamesbin armyops
+ dosym ${dir}/armyops ${GAMES_BINDIR}/armyops
+
+ prepgamesdirs
+ make_desktop_entry armyops "AA: Operations" ArmyOps.xpm
+
+}
+
+pkg_postinst() {
+ einfo "To play the game run:"
+ einfo " armyops"
+
+ games_pkg_postinst
+}
diff --git a/games-fps/americas-army/files/armyops b/games-fps/americas-army/files/armyops
new file mode 100644
index 000000000000..9dd669ff8d2c
--- /dev/null
+++ b/games-fps/americas-army/files/armyops
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd GENTOO_DIR
+./armyops $@
diff --git a/games-fps/americas-army/files/digest-americas-army-170 b/games-fps/americas-army/files/digest-americas-army-170
new file mode 100644
index 000000000000..86685f8e0655
--- /dev/null
+++ b/games-fps/americas-army/files/digest-americas-army-170
@@ -0,0 +1 @@
+MD5 9ddb191395c679875e6001651af715d6 armyops-lnx-170.sh.bin 331772116
diff --git a/games-fps/americas-army/files/digest-americas-army-190 b/games-fps/americas-army/files/digest-americas-army-190
new file mode 100644
index 000000000000..f0abc6c7664a
--- /dev/null
+++ b/games-fps/americas-army/files/digest-americas-army-190
@@ -0,0 +1 @@
+MD5 cda9fb6fa330e7c524732da4a304ad87 armyops190-linux.bin 528545580
diff --git a/games-fps/americas-army/metadata.xml b/games-fps/americas-army/metadata.xml
new file mode 100644
index 000000000000..8c138035c67c
--- /dev/null
+++ b/games-fps/americas-army/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>wolf31o2@gentoo.org</email>
+ <name>Chris Gianelloni</name>
+</maintainer>
+<longdescription>
+America's Army is a first-person 3-D shooter designed and coded by the US Army to provide a realistic simulation of actual combat for US Army forces. The game is designed to provide provide civilians with insights on soldiering and to raise awareness about the US Army. The game was ported to Linux by Ryan "icculus" Gordon under contract from the US Army and is free to anyone.
+</longdescription>
+</pkgmetadata>